Software update on the 19th of September

#1

We have pushed a new release that contains the following changes.

my.autopi.io (43d1ff7d)

  • Changed dashboard to show most recent position
  • Various improvements to the software update page
    • Changed name to software updates
    • Much more stable
    • Now showing all changes made in table
  • Performance and stability improvements
  • Improved compatibility with older versions of IE
  • Preparations for new features
  • Improvements to events page

API

  • Improvements to the API documentation
  • Events endpoint has been improved
  • Added more documentation to endpoints (Also see new guide on community on how to get started using the API)
  • Performance and scaling improvements to the underlying storage systems

AutoPi Core

  • Added new commands to manage OBD protocols and perform CAN bus sniffing and playback. Highlighted new commands are:
    • obd.protocol - Change between ELM327 + STN11XX protocols and baudrate.
    • obd.send - Send a single CAN message on bus.
    • obd.dump - Dump all CAN messages on bus.
    • obd.play - Playback all CAN messages in file.
      NOTE: In terminal run obd.help for more details about the available commands.
  • Improved robustness of OBD connection which will among other things remedy premature closing of trips. For more details about these changes see: https://github.com/autopi-io/py-obd
  • Added new autopi command in Linux. When logged on using SSH you can now access all the usual terminal commands using the autopi command. For example: autop i power.status
  • Optimized system boot time.
  • Improved update release procedure for better handling of error scenarios.

The changes to the AutoPi Core is usually auto updated on all devices, but for this specific release, the auto update flag has been disabled.

And as always, any comments etc are welcome!

2 Likes
Updates to AutoPi Core - Beta testers needed
listed #2
#3

Update fails with error:
Error caught
TypeError: t is undefined

Br,
Mikael

#4

Hi Mikael

Thank you for reporting the issue! :sunny:
We have just pushed an update that fixes it, so you should now be able to update.

Best regards
/Malte

#5

Just updated my AutoPi.

Will keep you updated on any issues I may find with it.

BR
Sandi

1 Like
#6

After update the device keeps rebooting every few minutes, I get no data from the car.
Trying to read logs from console results in error message: ‘u’.

I tried running the update with the RPI3 connected to normal power connector and the update fails since it cant find all the devices (due to it´s not being powered through the odb port) 9 out of 104 updates fail.

I connected it to the car odb and the update goes through but the random reboot continues, I try to force the update to same version, the update triggers a reboot and I get no indication of the update completed or if it error-ed out.
What do I need to check and where to give you more details? :slight_smile:
Br,
Mikael

#7

Hi Michael, can you provide some logs?
You can retrieve them using the minionutil.last_logs command or by connecting via ssh. But it may be hard to get the timing right if it keeps rebooting :confused:

Is any data uploaded to the cloud? Events trips etc?

Best regards
/Malte

#8

Hi,
I cant read any logs through the minionutil as it throws an error, It stays online for a minute or two so I can get ssh access for a short while when its connected to the odb. If I power up the RPI3 using USB power it stays online as long as it has power.
No data is uploaded while connected to the car except when forcing an update.

How do I get log data out from SSH (if minionutil throws an error), I can also provide a full disk image in worst case if needed.

Br,
Mikael

#9

Did get some logs out after 3 tries to push the new config. Will send you a message directly since the logs contain my device id.

Br,
Mikael

1 Like
#10

Hi Mikael

The update went through without errors at some point right?
Can you try to run this command? - and send the output.

power.status

It does seem like currently, that the issues you are experiencing is not happening for anyone else, so it may be something specific to either the RPI3, or maybe an edge case in the software running on your device.

Best regards
/Malte

#11

command responds with:

power.status

error: >-

Failed to connect to interface ‘<class ‘obd.interfaces.stn11xx.STN11XX’>’ -

see log for details

and with car running I get:

power.status

An error occurred. Received Unknown Error from server.
Br,
Mikael

#12

Good morning,

Since I updated to last version, I had problems with my GPS and data seems wrong.
I tried to update it twice, but same happens.


I’ve been driving in Barcleona, and Madrid Maps appeared. so it seem no gps position are stored or represented in openstreetmaps.
Speed seems wrong also.

What can I do?.

Thank you.

#13

Hi NCG

We have some terminal commands that can be executed (on my.autopi.io 1 and local.autopi.io) to view the main log file:

minionutil.last_logs
minionutil.last_errors
minionutil.last_startup

These functions can also take various parameters. To see the documentation run:

minionutil.help

If logged onto the system using SSH you can view the log file by running:

less /var/log/salt/minion

Can you grab the log file via SSH or a part of the logfile via the above commands and send that to support@autopi.io so that we can investigate further?

Best regards
/Malte

#14

Hi Malte,

Updated twice after new release. And works fine.
GPS orientation is as always.

By the way I have 2 tokens registered, old one and the current.
Is it possible to delete the old one?. token Description name: Autopi_Old

Than you.