2008 Prius Help

I recently received my AutoPi and I’m trying to fully set it up. Previously I owned a Verizon Hum+ and before that an Automatic. Both were able to read things like fuel level from my 2008 Prius (Gen2) without a problem.

But so far I’m unable to get any data from the car. I’m still very new to all of this, so I’m happy with ‘RTFM’ answers as long as I know what terms and concepts I should be digging into.

The CAN Analyzer is unable to find anything, so I think/hope it’s just a configuration change I’m missing.

Hi @geekquixotic,
Welcome to the AutoPi community!

Generally, the AutoPi is able to get data from vehicles that follow the OBD-II standard. Unfortunately, however, not all vehicle manufacturers follow that standard fully and that may be the case with your vehicle too. Furthermore, the AutoPi needs a bit more setup to get fully working for non-ICE vehicles (Internal Combustion Engine vehicles). Take a look at this guide for more information.

What have you tried to do to get data from your vehicle? Have you tried out our PID Tester utility, which you can find in Car Explorer > CAN Analyzer > PID Tester? Please note that in order to see the Car Explorer tab, you first need to enable the CAN Analyzer add on.

With the PID tester you are able to send PIDs to your vehicle and receive data back. For your particular car model, I have found a spreadsheet with possible PIDs that you can use.

Use this link to download the spreadsheet.

This spreadsheet was found under this article.

If you need further support, feel free to contact us by sending a mail to support@autopi.io.

Best,
Dragos