Software update on the 27th of May - Custom services, improved local configuration tool, improved can analyzer

Software update on the 27th of May - Custom services, improved local configuration tool, improved can analyzer

We have pushed a new release that contains the following changes.


New functionality:

  • Added ability to see events overlay in the map, to see exactly where and when which events occurred.
  • Added feature to allow the user to see state of device and approve if not approved, like after reflashing device.
  • All services, including system services, is now visible in the services section, where it’s possible to reconfigure, delete and override them.
  • Added ability to create custom services via the custom code section, with custom pip requirements
  • Added warning if no loggers exists to help users troubleshoot no data in cloud

Fixes and stability improvements:

  • Many improvements to the CAN Analyzer
  • Minor changes to the CAN Message editor
  • Improved mobile view
  • Fixed minor issues on the dashboard
  • Fixed minor issues in services
  • Fixed issues with worker names
  • Changed to now create alert if update fails
  • Fixed minor errors in services
  • Fixed issue in Car Library when duplicating PID or CAN Message if bus already exists
  • Improved readability
  • Removed logbook/most_recent_position/ endpoint (use logbook/most_recent_positions/ instead)

AutoPi Core

New functionality:

  • Added ‘workers’ and ‘reactors’ to all services.
  • Added option ‘auto_start’ to workers. Now it is possible to create a worker which does not start automatically after boot. It can then be started later manually or by an event reactor when a specific event occurs.
  • Jobs moved to separate configuration file on device to ensure jobs are always started even when device is offline during boot process.
  • Broadcast notification to all logged on users when:
    • Sleep timer added
    • Update release initiated
    • Update release completed
  • Support for adding custom services (via custom code).
    • Support for installation of 3rd party PIP requirements
  • Performance optimization of CAN monitor/dump.
  • Reporting of kernel errors (dmesg) in events with tag ‘system/kernel/error’.
  • Added warning in header of system configuration files managed by AutoPi.
  • Modifications for support of new TMU device:



  • Added event ‘system/minion/ready’ that is triggered af startup.
  • Added events ‘system/minion/online’ and ‘system/minion/offline’.
  • Renamed event ‘system/minion/restart’ to ‘system/minion/restarting’.
  • Renamed event ‘system/device/ec2x/power_off’ to ‘system/device/ec2x/powered_off’.
  • New event ‘system/power/3v3/restarted’ if modem is restarted.
  • Fix in ‘rpm_motor_event_trigger’ to not send ‘vehicle/engine/’ events but 'vehicle/motor/’.

Advanced settings:

  • Allow automatic update of release on startup.
  • Added settings to configure DHCP of WiFi hotspot.
  • Added setting to disable HDMI display.

Local configuration tool


  • Many improvements to make the tool more responsive to connection changes.
  • Improved 4G/LTE and WiFi config to show more details if issues occur, to ease troubleshooting considerably.
  • Added new view to show details, and allow downloading logfiles directly.

The update takes quite a while to finish, and it will restart the services running on the device. So please be patient when installing the updates, it should finish by itself, or retry on errors.

Let us know if you experience any issues.

As always, feedback, comments etc are welcome!


My wifi died since the update :frowning: and during travel, I see that my trips have missing kilometers as if it shutdown when driving.

Yesterday I saw lots of wifi hotspot disconnection during driving and now I can’t see the wifi anymore, I reset the ssid and password but same problem, no more hotspot :cry:

I can only connect with 4G to my autopi

How to install the previous version ?

Yesterday I wanted to delete my post because wifi hotspot was working again after some random actions, but today I drove few kilometres with wifi working and 30 minutes later to come back at home, wifi hotspot again disappeared !

I want the previous version which was working better, how to roll back ?

Edit : same problem tonight, I drove few kilometers with hotspot OK and after diner (30/45 minutes) at startup of the car no more wifi hotspot.

minionutil has lots of errors of this kinds, what to modify ? :

$ minionutil.last_errors

2020-05-30 18:02:09,687 [messaging :742 ][ERROR ][757] Exception
while processing event: {‘tag’:
‘obd/req/xxxxxxx-7a8f-4105-a352-xxxxxxx52060’, ‘data’: {’_stamp’:
‘2020-05-30T18:02:08.341153’, ‘args’: [‘Relay_Ignit’], ‘_event_tag’:
‘obd/req/xxxxxxx-7a8f-4105-a352-xxxxxxx52060’, ‘kwargs’: {‘baudrate’: 500000,
‘protocol’: ‘6’, ‘verify’: False, ‘pid’: ‘101’, ‘bytes’: 64, ‘header’: ‘7E4’,
‘mode’: ‘220’, ‘decoder’: None, ‘formula’:
‘bytes_to_int([53:54])’, ‘force’: True}}}
2020-05-30 18:02:11,566 [messaging :742 ][ERROR ][757] Exception
while processing event: {‘tag’:
‘obd/req/xxxxxxx-400f-b8c2-xxxxxxx’, ‘data’: {’_stamp’:
‘2020-05-30T18:02:10.887442’, ‘args’: [‘batpwr’], ‘_event_tag’:
‘obd/req/xxxxxxx-400f-b8c2-xxxxxxx’, ‘kwargs’: {‘baudrate’: 500000,
‘protocol’: ‘6’, ‘verify’: False, ‘pid’: ‘101’, ‘bytes’: 64, ‘header’: ‘7E4’,
‘mode’: ‘220’, ‘decoder’: None, ‘formula’:
‘force’: True}}}
2020-05-30 18:02:19,052 [messaging :206 ][ERROR ][757] Recurring
exception (195 times) in worker thread ‘pid_logger_5_0sec’ while running
workflow for message: {‘filter’: ‘alternating_readout’, ‘handler’: ‘query’,
‘returner’: ‘cloud’, ‘args’: [‘Charging_Power’], ‘kwargs’: {‘formula’:
‘pid’: 101, ‘force’: True, ‘mode’: 220, ‘header’: ‘7E4’}}

I have same issues: Wifi disappeared and no cloud connection anymore.
Tried plugout-plugin device several times.
Tried plugout - remove SIM-card - plugin.
Tried plugout - remove SD-card - insert SD-card - plugin
nothing helped.
How to diagnose problems? Only way is to read SD-card directly. Which files are interesting?



AutoPi does not update, I have daily update errors

Unable to process requirements file “/etc/pip-requirements.txt”. Error: Looking in indexes:,
Collecting git+git:// (from -r /etc/pip-requirements.txt (line 12))
Cloning git:// (to revision e257773cee103f16f75dd1ea4f9e2ef64645540a) to /tmp/pip-req-build-d5KmSa DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at
Running command git clone -q git:// /tmp/pip-req-build-d5KmSa
error: index-pack died of signal 11
fatal: index-pack failed
ERROR: Command errored out with exit status 128: git clone -q git:// /tmp/pip-req-build-d5KmSa Check the logs for full command output.
WARNING: You are using pip version 19.3.1; however, version 20.1.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

Someone can help me ?

I just follow this link Guide: Reflashing your device to flas the previous version but I have a problem :on the link I have to “Remember to update your device from the cloud after you reflash it, as that will ensure that all the configuration values are properly configured (like the WiFi SSID and password), and that the device has the correct authentication token for uploading data to the cloud.” but If I update I will have the may 2020 new version again instead of the December 2019 that I just installed.
How to update the configuration value for the previous version ?

Wanted to comment that on my end the upgrade went without a problem here, and I’m really loving the new map features.

I’m driving less with my job temporarily moving to work from home, and the AutoPi has been helpful for keeping track of my vehicle’s health remotely. I use the voltage graph as a gauge of when to start the car to keep the battery healthy.

I hope that everyone is doing well and look forward to doing some road trips in the future!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.