Can't use AutoPi software on RPi. Local API is not yet ready

Subject of the issue

I’ve been trying different things for a few months now, but I always give up on the end. So the problem is that I cannot log in or use autopi software not even when I ssh into it. If I try to access it via, the site successfully loads, but I get a message "Connected to a local device, but local API not yet ready. Please wait..". The message doesn’t change even if I wait for an hour or so. I tried to ssh into the dongle, and I successfully did that, but when I try to use autopi’s command(like autopi power.status), I get an error "-bash: autopi: command not found". What can I do? Screenshots from terminal and website are on the bottom.

Your environment

My dongle version is probably _2018.01.01

Steps to reproduce

It happens to me every time I connect to autopi dongle.

Expected behaviour

I would expect to login and use AutoPi services.

Actual behaviour

Can’t log in, says that local API is not yet ready nad it keeps showing that for ever.

Output of power.status command

I did run that command via terminal when I did ssh into the dongle, but it said that command was not found.

Run the command


in the terminal on, and paste the result here.

-bash: autopi: command not found

Screenshot%20from%202019-06-07%2010-55-43 Screenshot%20from%202019-06-07%2011-04-45

I get this when i use an odd browser on my phone, usually it works fine in Chrome.
But your issue feels way diff rent

For users that may have similar problems in the future:

I’ve just reflashed my AutoPi Dongle and it works now!