Can't connect to AutoPi

Subject of the issue

I have 2 issues here. So the first thing is, that I cannot connect to my autopi. When I successfully connect to AutoPi hotspot I try to configure the device via After I connect to the web server, I get the following error: Connected to a local device, but local API not yet ready. Please wait..

I tried to reboot the autopi, same error… then I thought that autopi is not getting enough power since my car was not started. I started the engine, rebooted the autopi, wait for about 3 minutes, tried… and the same result.

After that, I tried to ssh into the device, since I was able to connect to autopi hotspot. I did successfully ssh into the pi, tried to run some commands like autopi power.status and I got this error: -bash: autopi: command not found Even If I try to just run autopi something I get the same error. I even tried with sudo but no luck.
After a few minutes, my laptop lost connection with autopi (ssh and wifi had disconnected) - I don’t know why but I’ve checked and the green light in autopi housing was still on.

I did not completely configure APN settings yet since I had some problems with my sim card. And while I was trying this, I did not have any sim card in the device. Is that a problem why the API doesn’t load?

What should try next? Thanks

Živijo :slight_smile: (wow so many Slovenian people on here haha :smiley:)

AutoPi will turn off after some time of not getting back RPM data. It’s strange you got a reply back with command not found.
Let me try executing the same command as you. You probably can’t check what version you’re running at the moment?
I dont’t think not having a SIM card inside should be an issue.

1 Like


Because there was no activity for a while at the topic I close it. If your problem still exists or find another one, please do not hesitate to open a new topic or mail to

Best regards,