Where is all functions? Widget, Car Explorer, etc

#1

Hi,
I’ve received yesterday the Autopi 3G and WiFi.

I’m succesfull registered on my.autopi.io but where is possible to:

  • Add widget
  • Manage Alerts
  • Use CarExplorer
  • Create Automation
  • Add Add-on

as described in this videos? https://www.youtube.com/watch?time_continue=79&v=TF38GRbjO9s

Unfortunately I don’t understand why but in my client panel I’ve limited function and there isn’t function mentioned above.

Why ? This is very frustrating after paying 300€

3 Likes
#2

Hi @matteo.filosa,

Glad to hear that you are up and running.

Some of the menu points have changed names, since the videos was made. This is to get a better usabeility in the Cloud.

Alerts is Events
Diagnostics is Trouble Codes
Automation (reactors) is Triggers
Widgets and Add-ons is included in the Custom Modules and Jobs (use these to make your Add-ons)
Car Integrator has been moved to the Terminal interface. See here how to use it: (Using the CAN bus commands)

The Car integrator will also be available directly from the Cloud UI from the next version being released.

We have added a couple of areas that isn’t in our video (dongle status, software updates) and as such new areas will be released when they are needed.

Let me know what it is your are planning to build and I might be able to guide you in the right direction.

best
Peter

#3

Ok thanks so I ask,

how I can add more widget? I don’t find the button ADD WIDGET. I want to change bar to gague for temperature and fuel level.
I want add widget called fuel efficiency

In the video in Add-on section there is many add-on from the library but following what you’ve wrote if I go into JOBS i can Create job as a cron job but I cannot browse library

I want also to configure reactor to notify me by email or sms when car is powered on.

Sorry Peter but nothing of this I can found in new interface.

Please try to understand me and give me instruction on how to find this.

See attached what i can see on my client area

1 Like
#4

Hi Matteo,

No problem, we are here to help :slight_smile:

As of now you cannot add new widgets, this will be available in one of the next releases. But temperature and fuel level is already shown as widgets in the dashboard. We currently log both the Intake temperature, Fuel level (%) and the temperature inside the RPi. All of this is in the dashboard and you can see it when you’ve made your first trip.

Yes you can pretty much add any job you want under Jobs. For now they are limited to a CRON schedule, which means that they cannot run more often that once every minute.

You can configure reactors under the Trigger section. Here is a guide on how to do that:

You can use webhooks to interface any external system you want.

Best
Peter

#5

Sorry where I can find add on library ?

#6

Peter,
sorry but I don’t have any answer here. How is the library showed here? FUNCTIONS

I’ve purchsed Autopi to implement Remote Start, Parking heater.

Thanks in advance

2 Likes
#7

Hi Matteo,

The page you refer to is our Use case page.

The AutoPi you received is an IoT platform where you can built your own system on top of. The use case page contain ideas to what you can built on your own. The device is ready for you to start building on top of it.

best
Peter

#8

I bought the device watching the deceptive video they have for selling the product “you have option to add multiple widgets/add-ons available in our gallery with a single click, which is growing every day!”

Received the device today only to find out I’ve to create everything myself, thinking of sending the device back.

2 Likes
#9

Hi Agn

FYI - the dashboard has an update coming out in the next few days which makes the dashboard configurable, with customizable widgets.

Best regards
/Malte

2 Likes
#10

@Malte Thank’s.
I hope we will have for EV car too ;).

2 Likes
#11

Hi Remy

This will actually also benefit you EV guys too, as it allows to retrieve any data that is logged, and not just the default configured stuff. So when we have the other changes ready, you will be able to have custom widgets that shows custom data from your EV’s :smiley:

Merry Christmas!

Best regards
/Malte

2 Likes
#12

@Malte Thank’s :smiley:

#13

Hello,
How do I determine which version of software I have running and compare that to the latest available version?
When I try to force an update I get the response “updated” if I continue to update I get warning messages and the update fails to complete or the message “retrying”
I have a couple of issue that may or may not be software related:

  • CAN Bus discovery get stuck on “PROTOCOL” - “Getting default protocol Please wait” then “PROTOCOL” - “Getting default protocol” with the spinner and nothing ever comes back, also unable to clear the pop up message

Wayne

#14

Hi @waynez

You can always check your device status on the “software updates” page. The CAN bus commands has been added in some of the latest versions, so make sure its up-to-date.

Also, when you do the CAN bus discovery, please make sure your engine is ON (but not while you are driving). Otherwice the ECU might not respond correctly.

best
Peter

#15

Thanks Peter,

One other thing that I missed - I don’t seem to be able to change the wifi SSID, the save button is greyed out

settings / dongle / advanced / wifi

Wayne

#16

Hi @waynez,

Its not possible to change the WiFi SSID locally, this is only configuration for what WiFi the device will connect to in client mode. But you can do it from the cloud.

If you log on to my.autopi.io, then you can change the WiFi hotspot settings under:

settings->dongle->advanced->wifi

best
Peter

#17

On that page, using chrome, ctrl+shift+c then select the save button, you will see a value “disabled” remove it and it will become active, click save.

#18

Hi Waynez

The disabled save button is caused by an issue that is already fixed, but not yet released.
Basically if the general tab is not ‘valid’ - usually if the call name input field does not have a value, the save button on the advanced tab is disabled too.

The workaround is to make sure the general tab is valid, ie. input a call name for your device, then you should be able to save the advanced settings too.

Alternatively, you can also do as @agnostic suggests, by using inspect element to enable the button, by removing the ‘disabled’ attribute.

Best regards
/Malte

#19

Thanks - WIFI change has worked

Still no luck with CAN BUS - just sits there Getting Default Protocol

Is there a log somewhere to see what it’s looking for and what it’s doing?

#20

Hi @waynez,

Can you send an email to support@autopi.io with a description on what you have done so far and what the issue is? They will be able to assist you with this.

best
Peter