Verizon Wireless - US will not activate these devices

Subject of the issue

Verizon refuses to activate device on their network.

Your environment

4G/LTE Edition
North America 4G/LTE region (Verizon)

Steps to reproduce

Attempt to activate device on Verizon Wireless network.
I got the IMEI number from the Quectel LTE EC21-V chip on the device.

Expected behaviour

Verizon specific dongle would be allowed on the Verizon network.

Actual behaviour

Enter IMEI into Verizon activation system. Verizon message- “Cannot activate because it has no GPS. Call customer support.” Customer support- “Not valid on the Verizon network because it does not support E911” (US emergency number that when connected to call center, provides location of caller). Apparently, E911 is required on all devices operating on the Verizon Wireless network.

Has anyone in the US activated their dongle on the Verizon Wireless network. If so, what do I say to the rep/sales person to get me to a person that will do it? I have tried multiple Verizon stores and called Verizon support multiple times hoping I would find someone that could help.

The only response I get from Verizon is that this device is not compatible with the Verizon network. They do know it is a data modem.

Hi @tedgenyc

I’m taking it that it was this guide you have been following:

As far as we are aware, it should be possible to use Verizon activation system. Essentially the AutoPi will just appear as a data modem (as you say) in their network. They have some other data modems, even a plan to “bring your own device” which is what you do:

For the record, the AutoPi has both a GPS and eCall built into it.

What happens if you active the SIM on another device (like your smartphone) and then just insert it into the AutoPi? Will it work then?


I already have a Verizon account so I was trying to add a “bring your own device” device via the account pages and by calling Verizon support and going into the Verizon store to have them do it. In all cases, I/they are stopped at entering the IMEI. Their system responds to my online request with “can’t activate because it has no GPS”. It responds to them with “no E911 capability”. Both responses are a stopping point for network activation.

I looked at the knowledge-base article you referenced. It states “For first-time setup, launch a web browser session”. I have not tried that. How shall I do that? Disassemble the dongle, HDMI monitor on the Pi, keyboard, default userid/pw for Pi, web browser?

I had thought about activating the SIM on another device but couldn’t because of different SIM sizes.

Hi @tedgenyc

The AutoPi doesn’t include a graphical interface with a web client. This has been removed for speed purposes.

If you are conneted to the WiFi hotspot with a smartphone/notebook then you may be able to start a browser from you phone, and thereby entering the IMEI.

Other than that, can you try with another Verizon sim you have? Maybe the one for your phone?


When connected to hotspot with phone, I can only connect to Phone states connected, no internet.

The SIM card for my phone is a smaller size.

Do you have any change of getting a SIM adapter to test with the SIM card in you phone?

I’ll order one and give it a go.

I must be the first person in US with AutoPi dongle for Verizon.

Well, you are the first we heard from. There are others out there, but I’m not sure what they have done. If we hear from them I’ll report back to you.

My best bet for you is to see if you can active the SIM card on another device.

Just walked out of the Corte Madera, CA Verizon store and they said they did not support this device and advised me to go to AT&T. They also tried to sell me their own OBD device:

Told them no thanks, but definitely a little bummed.

Hi Mamboozo

Your issue right now is that you need to activate your sim card right?
Do you have another device that you could temporarily use to activate it? You should have received the sim card from your provider with several sim card adapters.

Like so:

If your phone needs a smaller sim card, you should be able to just push out the nano sim card from the one you received, activate it using your phone, and then afterwards insert back the sim card in the cutout, and then insert it in the autopi dongle.

Best regards
/ Malte

Hi Malte,

The problem is that Verizon needs a serial number to activate the sim. When I gave them serial number of the Autopi, they said they could not activate a SIM based on serial number I gave them. In short, they do not sell sim’s without a device assigned to it, which is why they directed me to AT&T. So in short, Verizon doesn’t support selling “naked” sims but AT&T and T-mobile will support it. I could probably take a sim from another device, which I may try. If I do, I’ll circle back.


@Malte @Peter

Update on Verizon:

  1. I went back to the Verizon store with my documentation from Autopi confirming that I bought a Verizon compatible Autopi dongle. This time I got a more knowledgeable (and less lazy) clerk who was helpful. The main issue is this: Verizon needs an IMEI number to issue a number to a sim. The IMEI on the Autopi will not work. We opened the case and got my dongle’s IMEI, but the system will not recognize it as a connected device.
  2. So I got a IMEI from an iPad that had been on the account in the past and got a nano sim then bought an Nano -> Micro adapter. Verizon can only issues sim sizes to the size associated with the device, so there was no way to get a macro sim. I tried setting up the nano sim with adapter in the dongle, but it still would not get cloud connectivity.
  3. So I put the Nano in an android phone and made sure that connectivity and data was working. I confirmed that data and connectivity was there, but it took the phone to enable the sim with Verizon. Note: To be fair, when I first put the sim in the dongle, I tried adding “Verizon” and " vzwinternet" to the settings, but it turns out Verizon does not want any information in these fields to work. So the guidance should be to leave the fields blank after confirming connectivity in another device before activating in the dongle.
  4. I put the sim and adapter back in the dongle, connected to the dongle’s wifi and was able to confirm connectivity through as well as reaching other sites while connected to the dongle’s wifi.
  5. I am still unable to see the dongle or confirm connectivity in One thing might be causing the problem is that I had already previously registered my dongle before acquiring connectivity.

Any suggestions?

I’m right there with @mamboozo! Finally, locally, I have connection (one huge step forward). I added an old Verizon phone (Samsung S5 with a micro SIM) to my Verizon account as a bring your own device. When that SIM is inserted into the AutoPi, CONNECTION. Yay. Except…

Same as @mamboozo, no connection in I am using “VZINTERNET” as the APN string. I also previously registered my dongle before acquiring connectivity.

I attempted to register my dongle again but received reply that “An AutoPi dongle with that ID was not found”.

@Peter/@Malte, a point in the right direction would be much appreciated.

I tried shutting down the AutoPi, disconnecting, and reconnecting according to this article thinking it might reset something but to no avail. Same issue.

@tedgenyc nice to know that I’m not crazy. :wink:

I’m hoping we can get it fixed!

Agreed. Since it cannot be used via WiFi :disappointed_relieved:(upload to cloud via separate hotspot), we currently have a $300 paperweight on our hands.

I’m sure the guys will work something out for the Verizon models. Fingers crossed. This is the cost of being on the front end of something new.

Hi guys

We are on it.
From what i understand, you are able to connect to the internet via the hotspot right? - but it doesn’t say it’s online on

Connecting via WiFi is on our roadmap, so you will be able to get it online this way in the near future.

Best regards
/ Malte

Malte, that is correct.

Hi Tim

Can you try to run the following command, in the local terminal while connected via the hotspot, and send me the response?


Thanks in advance

Output (Google Drive file)