Using roaming with a data sim card

Hello,
I have a question about using an sim card where it is necessary that roaming is switched on.
I am using a sim card from “Keepgo” in Holland. I have it tested in my mifi hotspot. Its working very well.
Only one setting is important to use the “keepgo” sim card, and that is roaming. It must be switched on, because “keepgo” use the network from KPN. Do you have a solutions for this problem, because this setting is not available in the local.autopi.io gui.
Regards,
Ron

Hi @RonJBakker

Yes is possible to enable roaming by writing AT commands directly to the modem. We are working on implementing this graphically as a setting on your device, but for now you can use these commands:

Default (current):
ec2x.query 'AT+QCFG="roamservice"'

Enable:
ec2x.query 'AT+QCFG="roamservice",2'

Disable:
ec2x.query 'AT+QCFG="roamservice",1'

I’m not sure if the modem will remember the setting after a restart, but you can try it out until we get the settings complete.

best
Peter

Hello Peter,

Thanks for this answer, but it is not working. See the screenshot

I hope you can tell me what I am doing wrong.

Regards,
Ron

Hi Ron

Roaming should actually be enabled already.
Can you confirm that the SIM card is not working with the default roaming setting?

What you are seeing is a small but in this case blocking issue with the terminal, that we have already fixed, but it’s not ready to be released just yet, as we have more testing to do.

Best regards
/Malte

Hello Malte,

The sim card (keepgo) is not working with the default settings. See screenshot.

The sim card is tested in a mifi device E5577C from HUAWEI. I have also an other sim card (only data from T-Mobile) and that is working very well in the autopi. But that sim card is normal used in the mifi device for my dashcam from blackvue dashcam (cloud version).

Regards,
Ron

Hi Ron

I believe the default value is something like ‘automatic’, and your SIM card may need it to be explicitly enabled.
I’l get back to you with how you can enable it via the console.

Best regards
/Malte

Hello Malte,

Thanks for the reply. I received my autopi a while ago and now I found the time to use it in my office (before putting it in my car).

I have read in the community there er is a solution to connect an 4g autopi to a wifi point. Maybe this is a solution for me since I have wifi available. Can you tell me how to connect with my wifi point?

Regards,
Ron

Hi Ron

You can try this command, but you will have to log into the device via SSH. See this guide for more info
It will enable roaming.

curl -X POST -H "Content-Type: application/json" -d '{"command":"ec2x.query","arg":["AT+QCFG=\"roamservice\",2"],"kwarg":{}}' http://localhost:9000/dongle/YOUR_UNIT_ID/execute/

Then you can use the following command to confirm whether or not it has been set correctly.

curl -X POST -H "Content-Type: application/json" -d '{"command":"ec2x.query","arg":["AT+QCFG=\"roamservice\""],"kwarg":{}}' http://localhost:9000/dongle/YOUR_UNIT_ID/execute/

Regarding connecting to WiFi then yes, it’s possible, but it’s not really officially supported yet, but check out this guide if you’d like to try, or if the above command doesn’t work.

Best regards
/Malte

Hi Malte,

Thanks for the response. The commands to enable roaming don’t work. I have used the OBD power cable, connect a screen and keyboard to use SSH.

The second method, connect the autopi to my mifi device, works perfect. So, problem solved!

I have more questions, but I open therefor a new thread in the community after I used the autopi in the car with the latest software release.

Regards, Ron

1 Like