Unplugging whilst driving: Not recommended!


Ok. Thanks. It is very strange. But ok. We should take care about that



I have same problem now !!!
But i haden’t remove the dongle when car is On
Just I saw it now. My car doesn’t want to put back or rear
What was succès ? Remove the battery for 10 minute ? I try to do it now.
What kind of app did you get to remove error ?
Please reply quick as possible. Thanks


That’s very concerning if it happens when the car isn’t running.

To fix it, disconnect the negative terminal of the 12v aux battery for 10 minutes to clear the error.

I used the CarScanner iOS app, but wouldn’t recommend it. It didn’t clear the error permanently.


Thanks, I had do it.
All is ok now, I had disconnect the battery negative for ten minutes.
what kind of error did you get ?
Maybe you try to clean before solve, and now, still again same error ?


Hi @Remy_Tsuihiji

The error I got was “Check electric vehicle systems” and the orange triangle with “! EV” was illuminated. Clearing with the app let me put the car into reverse, but then it was stuck in reverse! Only disconnecting the battery fixed it, and it’s not happened in the week since.

1 Like

Very worrying … can the autopi folks can comment on this ? Do we need to stop using autopi ?

Having said that, I’ve just completed a 600-odd mile long weekend with autopi plugged in and saw no ill effects.


Hey guys

We are looking into what might be the cause, but our working theory is that we currently have a number of PID’s that are continually requested, and for ordinary ICE vehicles, it’s fine, but for electric vehicles like yours, we believe that requesting the same data could potentially cause the issues you have seen.

Like, if you fuzz the CAN bus, ie. write random data to it, it can cause the same issue where it goes into an invalid state and the common fix is to disconnect the battery for a short while, so it’s not an uncommon fix when people do some of the more advanced CAN bus hacking, stuff like fuzzing the CAN bus by writing lots of random data to it, in order to discover flaws etc, something which using the autopi is not! - so this should never happen with normal usage.

I am however not sure how much we can do about the issue that occurred when the device was unplugged while driving, as that may be caused, not by our device, but instead by unplugging a/any device from the OBDII plug while data is being read/written.
But I completely understand regarding the voice speak, and we are making changes to it so that it will not speak the same notifications again and again.

Part of the changes we are working on is to customize the default configuration based on the type of the vehicle, so that you can set the type of the vehicle, and it will then consider the type when deciding what PID’s to retrieve by default, like skipping RPM for EV’s.

@Remy_Tsuihiji can you send the logs from your device to support@autopi.io?
That could likely assist in confirming our theory from above.

Best regards

1 Like

ok thanks you. how to get the log ? then I will send you. the problem with the car was the 17.


i upload now the image in the dropbox link.
I hope you can find something interesting for EV car issue.


Just to follow up on this. I’ve driven another couple of thousand miles with the AutoPi and no issues, until this morning.

We had a relatively short drive (about 10 minutes) with no issue, got out of the car and came back 20 minutes later. Upon starting the car I received the same “Check Electric Vehicle Systems” warning. And the car refused to select a gear, as before.

Luckily I now carry the spanner to loosen the nut on the aux battery, so disconnected for 10 minutes, and sure enough that cleared the problem. I disconnected the AutoPi at this time.

At the moment I can only assume that there’s some issue if ODB queries are in flight and the connection is lost? Whilst I’m confident some/most of the blame here lies with how Hyundai handle this condition, I’m now a little bit cautious about plugging the AutoPi back in.

Logging data tips

i’m completely new to AutoPi gen2 used for the Ioniq EV. not yet started but already worried that my Ioniq may also have problems. Is this KonaEV specific? Regards, Norbert


Hi @njordan,

Welcome to the community.

In the latest update we released a very minor core fix, which should have adressed this problem. We do believe that should solve the issues reported by the other users above. So please make sure your device is updated.

We still dont recommend that you unplug the device while driving, but other than that you should use it as you want.

If you see further issues regarding this, then please dont hessitate to reach out to support@autopi.io, they will be able to assist you debugging this.



OK, thanks but still makes me more confident if this was a KONA only issue. Or i will have to take tools with me every time i drive with AutoPi. from what i understand this was only seen related to Kona vehicles. Is that right?

Regards Norbert


Not sure if it helps or not, but I’ve not seen it on my kona .


For the sake of completeness, I should say I’ve seen it one more time since I last posted. It was earlier this week, whilst running the latest software (AFAIK).

The circumstances were once again that I had not unplugged it, I got back into the car after being parked for a couple of hours and noticed I could enter Drive. No warning light this time though. So I turned the car off and back on, and sure enough, the warning light came on.

Two minutes of the battery being disconnected seemed sufficient this time to reset the warning.


hui - that does not really make me feel comfortable. I’m electrical engineer and do a lot of IT projects but my car is something that i need to be able to rely on for my daily business. If i put this in my car and in the end its lottery if i will be able to drive or not, its not too confidence building - especially as it seems that its not 100% sure whats the reason is as the latest fix does not cover the issue.


If it helps, this never happened with my Ioniq.

And on the plus side, when the 12 V battery was at 7,5 V (my radio/headunit froze and drained the battery), car started. Not completely normally, the green “ON” icon flashed 3 times but then the car worked as if nothing happened.

Might be something different in the Kona though.


Hi @Steve,

I’m sorry to hear that you are still seeing this issue. Lets see if we cannot get down to the root cause.

Can you confirm the following:

  1. You are running the latest release of the AutoPi Core?

  2. You’ve changed your vehicle type to “Battery Electric Vehicle”?

Setting the type to “BEV” is part of the last update and should fix this issue.


1 Like

Hi @Peter

I am running the latest version, but I hadn’t seen the vehicle type setting, so thanks for pointing that out. I’ve now updated it, and we’ll see how it goes.

Thanks for your help, and for all the hard work we can see as the product has improved so quickly over the last few months.


1 Like
Kona EV setup & sleep

Hi @Steve,

Ahh okay, if you did not set “BEV”, then this should fix the issue.

But let us know if there is anything else.