Unable to update software

I am unable to update to the latest software on my V3 AutoPi. I always get the below message. How can I clear this and successfully update?

OPEN

Update release failed

HIGH

April 29th 2021, 19:43:14

April 30th 2021, 08:51:17

12

Title:

Update release failed

First occurance:

April 29th 2021, 19:43:14

Last occurance:

April 30th 2021, 08:51:17

Description:

Release ‘2021.03.10’ was not installed correctly because 11 state(s) failed. Retry attempt will be performed automatically at the next boot.

ID:

pip-requirements-installed

Name:

pip-requirements-installed

Duration:

72928.954

Start Time:

08:47

Comment:

Unable to process requirements file “/etc/pip-requirements.txt”. Error: Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple Collecting git+git://github.com/autopi-io/py-nmea@e257773cee103f16f75dd1ea4f9e2ef64645540a#pynmea2 (from -r /etc/pip-requirements.txt (line 13)) Cloning git://github.com/autopi-io/py-nmea (to revision e257773cee103f16f75dd1ea4f9e2ef64645540a) to /tmp/pip-req-build-SWkX_q DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at Release process - pip documentation v21.2.dev0 Running command git clone -q git://github.com/autopi-io/py-nmea /tmp/pip-req-build-SWkX_q fatal: Unable to look up github.com (port 9418) (Temporary failure in name resolution) ERROR: Command errored out with exit status 128: git clone -q git://github.com/autopi-io/py-nmea /tmp/pip-req-build-SWkX_q Check the logs for full command output.

Well after a day the unit shutdown due to critical battery voltage being met. After it rebooted due to driving, the software updated. What a fuss, but thankfully resolved. Maybe next time I’ll just pull the power, wait, plug back in :rofl:

1 Like