[SOLVED] Dongle not detecting properly?

#1

Hello,

I have a DIY dongle with RPI3. It is connected to the internet through a local hotspot.

On terminal, ifconfig tells me:

uap0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.4.1  netmask 255.255.255.0  broadcast 192.168.4.255
        ether b8:27:eb:26:fd:40  txqueuelen 1000  (Ethernet)
        RX packets 3784  bytes 519229 (507.0 KiB)
        RX errors 0  dropped 244  overruns 0  frame 0
        TX packets 3768  bytes 3298558 (3.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.74  netmask 255.255.255.0  broadcast 192.168.0.255
        ether b8:27:eb:26:fd:40  txqueuelen 1000  (Ethernet)
        RX packets 3554  bytes 3027701 (2.8 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2759  bytes 506723 (494.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

This is a fresh install using Etcher to flash latest release.

After I login device through http://local.autopi.io, there does not appear to be anything for me to configure other than Wifi since I don’t have a simcard. After I save, nothing else happens. The dongle is connected to internet through local hotspot, but on https://my.autopi.io/, the dongle remains red.

No matter how many times I restart the dongle, the “AutoPi-Initial” network remains available and I can connect to the local settings page, but the online/cloud page does not detect the dongle.

Also I note that when I access the “status” page on http://local.autopi.io/#/local, it’s not clear whether the dongle itself is being detected properly or not. Is there any terminal command I can run to test status of dongle?

RPI3 can properly access internet through hotspot:

PING google.com (172.217.25.142) 56(84) bytes of data.
64 bytes from syd15s03-in-f14.1e100.net (172.217.25.142): icmp_seq=1 ttl=52 time=7.75 ms
64 bytes from syd15s03-in-f14.1e100.net (172.217.25.142): icmp_seq=2 ttl=52 time=7.74 ms

I don’t what else to do.

Please help.

#2

Turns out you have to email support to reactivate the dongle every time you flash, at least for now.

#3

Where can you get the image to flash using etcher? Have been looking but haven’t been able to find it anywhere.

#4

Images can be found right here:

best
Peter