Software update on the 24th of October - Custom code and stability improvements

#1

We have pushed a new release that contains the following changes.

Cloud: my.autopi.io (e622436e)

  • Added new custom code feature that gives a managed way for you to push your own python code to your device via my.autopi.io
  • Added recent stats info that shows when your device was last online
  • Cleaned up the UI
  • Minor improvements to the trips map

AutoPi Core

Added new events:

  • power/recover is triggered when device has recovered from failure.
  • power/last_off is triggered when device is booting and contains the timestamp for last known system boot.
  • position/unknown is triggered when no GPS location is available (no fix).

New command:

  • audio.speak can speak given text.

Power changes:

  • Dongle will now hibernate (using ‘power.hibernate’ command) when ‘battery/critical_level’ event is triggered and will only boot when battery starts charging again.

  • Sleep time after inactivity when waked by timer has been changed from one to two hours.

Info: From the next release, all of the above sleep variables can be adjusted from my.autopi.io.

Bug fixes:

  • Fix: GNSS assist data not always updated if old assist data file already existed in cache. This resulted in prolonged time before first position could be determined.

  • Fix: Inactivity fallback sleep timer not always reset when engine is running which resulted in power down during trips.

  • Fix: Less triggering of battery/discharging events.

Note: Auto updates are currently disabled, but will be enabled again soon.
Currently the update takes quite a while to finish, and it will restart the services running on the device. So please be patient when installing the updates, it should finish by itself, or retry on errors.
Let us know if you experience any issues.

As always, any comments etc are welcome!

1 Like
Direct interface with CAN bus
My Autopi Interface
#2

Hi
Waiting for every update for functions for my Hyundai Ioniq electric :slight_smile:
How is it going?
I have the Autopi since start , but have no use of it yet.
I can use hotspot for a while , but becaus Autopi not recognise when car is on it shut down when drive,
And then the position is wrong to , because it says i am still on road :smiley:

1 Like
#3

Hi,

Just updated the autopi yesterday 23rd with success. Before I could see in events that my car battery was discharching with indication of my car battery voltage e.g. (12.8v) Now I can see still see the event discharging but not indication of current car battery level. Was this intentional meant to be in the update?

#4

Hi

Yes, the voltage is no longer added to the event, this value is logged in much more detail outside of the events.

Best regards
/Malte

#5

I have Hyundai Kona ev soon
I wait for same thing as you :wink:
I search how to do it but not find yet.
Nothing work on you ionic ? Only wifi hotspot ?

#6

Anyone with Toyota C-HR Hybrid? It Works?

1 Like
#7

can you describe how this works ? I tried using the default “my_module.test” , pressed the sync button and then tried to run it :

peter26@Volvol V50 $ my_module.test

'''my_module.test'' is not available.'
#8

Hi Peter

Hm, that sounds like you did everything correctly.

Did you get a success response when syncing the code?
You can try sshing to the device and checking if the code is pushed correctly to the custom core directory

/opt/autopi/salt/modules

Best regards
/Malte

#9

Still get reboot of device after few minutes, also still no data received from odb except on/off signal when car is started/turned off.

#10

Yes, when the dongle is powered I see success.

Okay, I’ll take a look. Thanks.

#11

This directory doesn’t exist. In /opt/autopi/ I see just audio and power.

#12

I can only see position, rpi temperature and battery voltage on dashboard.
And wifi hotspot work for a while but Autopi shut down when driving because it cant read if the car is on or not.
Just turns on when it charge the 12 v battery.
So not much use for me yet , But hope for a resulation soon :slight_smile:

1 Like
#13

Seems we have the same issue (But I dont get anything from ODB at all since it fails to connect). I will likely try to revert my HW back to AutoPi one from the RPI3 to verify if the issue is the same on different HW. If not then I guess I will need to start from scratch with a new AutoPi image on the RPI3.

#14

I can not connect to my autopi locally(no WLAN)after a crash on last update, but it is online(can see it from autopi cloud). Things to try?

#15

Well there is the option to force the update again from cloud if you want to try it again ? :slight_smile:

pinned #16
unpinned #17