Shutdown disable jumper not working

#1

Hi,

I’ve been running my autopi dongle without the saltstack software for a while (i.e. systemctl disable salt-minion). The reason is that I need high performance logging, so I have a separate logging script running instead. It has worked like a charm for months. In order to avoid reboots from sleep timers or low battery (I run it on separate power supply anyway by mod to the OBD-cable), I put the jumper next to the OBD-connector. It has worked well. I don’t have to give SPM heartbeats even, I only have to talk to it to enable 3V3.

Problem: the SD card has been corrupted, kind of. A few critical OS and application files start to contain garbage data at some parts, sometimes. It seems like this issue happens when the card becomes hot. I’m not surprised, I’ve had problems with these kingston cards before. The Internet seems to hint at the same thing: for reliability, look for the better brands. I will probably buy an industrial grade card to use in the future for improved reliability.

So, I tried to reinstall everything. I flashed the latest distro from here: https://github.com/autopi-io/autopi-core/releases/tag/v08.05.19
The problem I have is that, even though disabling salt-minon and reboot, the device powers itself off after a while (about 10 minutes). So, the salt-minion is not issuing the reboot as it is not running (confirmed) -something else is. Note that it is a software-initiated reboot as linux properly shuts down, it is not SPM cutting the power (been there and had that problem too in the past…). I’m not sure if SPM has that capability, but can it toggle some GPIO to tell the board to shutdown, and it obeys only in the newer disk image but not in the older one? Did you change anything in the latest releases? Do you have any idea of how to get rid of this behavior?

I am not sure which release I’m on for the corrupted card (since I got it flashed upon delivery with the device). Probably a year old or more. Any help would be much appreciated as debugging this sucks…

#2

…aaaand now it occurs to me that I had changed this too. The SPM seems to reboot the device after all thru ACPI or whatever that is called. This can be disabled by ignoring power button presses in logind.conf, like so:

Hope this helps someone!