Raspberry Pi 3B+ with AutoPI 4G/LTE Power Issue[SOLVED]

Has anyone ran into this issue while trying to get the AutoPi working with the Raspberry Pi 3B+?

I cannot get the 4G/LTE Board to be work over the usb connection. I’ve tried all the various solutions such as adding a udev rule, using the following syntax

ACTION==“add”, SUBSYSTEM==“usb”, DRIVER==“usb”, KERNELS==“1-1.3”, RUN+="/bin/sh -c ‘echo 1 > /sys/bus/usb/devices/1-’"

I’ve additionally added the “echo 1 > /sys/bus/usb/devices/1-’” line into the /etc/rc.local.

I’ve confirmed the device appears using lsusb and it identified the board correctly in dmesg but everytime I power up I get the following dmesg output:

usb 1- rejected 1 configuration due to insufficient available bus power
usb 1- no configuration chosen from 1 choice
usb 1- No support over 100mA

The 4G/LTE board was working fine with the Raspberry Pi Zero but I can’t for the life of me figure out why the board wont work with the 3B+.

Thank for any help



Just saw your post. I am facing a similar issue, but in my case it happens when trying to connect a webcam:

Although I have no solution, probably the fix will be the same, if we manage.


Alrighty, I finally solved this particular issue.

I used the pre-written rule in /etc/udev/rules.d/99-usb.rules as a starter point.
ACTION==“add”, SUBSYSTEM==“usb”, DRIVER==“usb”, KERNELS==“1-1.3”, RUN+="/bin/sh -c ‘echo 1 > /sys/bus/usb/devices/1-1.3/bConfigurationValue’"

From the output of dmesg I knew my usb device was 1-
I then ran the command:
udevadm info --path=/sys/bus/usb/devices/1- --attribute-walk

This outputted all the attributes of the usb device so I could match them properly in the udev rule. I had to change KERNELS=“1-1.3” to KERNEL=“1-” (no plural, just singular KERNEL) and then /sys/bus/usb/devices/1-1.3/bConfigurationValue to /sys/bus/usb/devices/1-

My final rule looked like:

ACTION==“add”, SUBSYSTEM==“usb”, DRIVER==“usb”, KERNEL==“1-”, RUN+="/bin/sh -c ‘echo 1 > /sys/bus/usb/devices/1-’"

This finally worked and successfully powered the usb port. I’m sure if I change ports I’ll probably have to write a new rule for that port.


Wow, thank you for this, @EthanM. I’ve been fighting with various modules for months. I had the MC7700, but then was told by Support that it would not work, and that an EC25 variant should work. Of course reading deeper, it seems they don’t support them all, really, which is likely why my EC25-AF didn’t work out of the box.

That being said, even though I can now hit the modem and have enabled all the gnss stuff that makes sense, I’m not getting any sort of data on the antennas. Shouldn’t I see trash coming in on the fix data, etc?

Also, if I want to use assist data, does that require a SIM to be inserted? I don’t have one installed currently.

Thanks again!

I’m glad I stumbled upon this as well. I also got my EC25-AF to register on my DIY Gen 2 edition. Now to see if I can get my data to work… Next hurdle here I come.

I know I saw some information about possibly having an option to add other GPS, USB, etc. through the dashboard somehow a few months ago. I believe it was in the GPS frequency query.

Wondering if that update is soon and/or alongside the Pi 4 support.

I couldn’t get my GPS to work, and support says it’s likely my antennas. I ordered a new one. Have you seen any data in the dashboard related to the unit?

That’s odd. My GPS appears to be working but I am using their GPS antenna from their site.

I’m currently trying to upgrade the firmware on my EC25-AF but couldn’t replace their updater with my files to make it work. So now I bought a USB to mini card to update it on another PC.

My GPS works now, with the above tweaks from @EthanM, and swapping out my MC7700 for an EC25-AF… plus tossing some old antennas and getting THIS from Sixfab.com. I did notice that my udev rule file seemed to revert itself to the old value… not sure when that happened. I might have to write a cron job to watch that, as AutoPi could be ‘fixing’ it with Minion.

Now onto more exciting stuff, like “Okay Google, roll down my windows”

I did some searching and I think you’re right about needing a script to keep the udev rule persistent. Peter mentioned something about that in the webcam query before.

Hopefully they’re planning to add a better USB management option going forward from the UI. I’m sure as the project grows more external USB options will come along.

I’m going to try using the immutable flag – because yeah it just reset itself again about 24 hours later.

Thanks Mate you made it worked my 4G as well :smiley: