Obd.query PIDS_A always returns null?

Installed AutoPi in my Citroën Xsara 1.4i (1999). After a few runs, still not getting data in the dashboard.
Ran obd.commands and obd.status with engine running to following output:


I thought that maybe my car, since it is an older model, doesn’t support OBD-II PIDs needed for AutoPi.

Looking online, I couldn’t find my model in the OBD-II support lists, and the ones similar to mine sometimes have only a few supported PIDs
(e.g. for Citroën Xsara 1.4 (2001 / 2002) supported PIDs for Mode 01 HEX result is 80100010, which results in support for PIDs 01 (monitor status), 0C (engine RPM) and 1C (OBD standards) - https://en.wikipedia.org/wiki/OBD-II_PIDs#Service_01 / )

Just to be sure, I figured I’ll see supported PIDs for my car by running

obd.query PIDS_A

but the outcome value is null.


I’m not sure if this is standard behavior of the platform as a safety precaution (since the top of the terminal reads “AutoPi.io Cloud Terminal - Use with caution” :slightly_smiling_face:) or maybe I’m trying to query it wrong, or my car can’t work with AutoPi :frowning_face:

HI Marko

What happens if you run this command? - it should also give you the available commands. But of course, only the ones within the OBD2 spec.


Since the autopi dongle uses the standard OBD2 PIDS, I don’t think it’s a device specific issue.

Was the engine on when you tried the obs.status command?

Best regards

Hi Malte,

Here is the output of the obd.commands with the engine running:


The obd.status command from my original post was ran while the engine was stopped. I did try running it while the engine was running, but the output is pretty much the same (only battery voltage differs):


Hi @rizha,

Can you try to run the same commands when the AutoPi is inserted in a newer car? This will tell us if its because your vehicle doesn’t support the OBD spec.


Hi @Peter

I connected AutoPi back in my car (Xsara 1999) this morning after leaving it out for a few days. Today I actually got some information on the dashboard, so I guess it started working.
I’ll run the commands later to see if something changed in the output. :slightly_smiling_face: