No SIM card present and No OBD information

Subject of the issue

I inserted a 4G SIM card and setup APN but the device is not online. I followed the steps described here but the command cmd.run "qmi-manager up" returns “No SIM card present” error. I tried with 3 SIMs, two nano SIMs with appropriate tray and one micro SIM. All three returns “No SIM card present” when the cmd.run "qmi-manager up" is executed. The SIM is inserted in the right direction described in the Getting Started document.

Your environment

4G/LTE AutoPi Dongle

Steps to reproduce

  1. Insert SIM card
  2. Connect to “AutoPi-xxx” hotspot
  3. Navigate to local.autopi.io
  4. Take terminal
  5. issue the cmd.run "qmu-manager up" command

Expected behaviour

The device should be online and connected to AutoPi Cloud

Actual behaviour

The device is not online and throwing “No SIM card present” error when cmd.run "qmi-manager up" command is executed

Here us a photo of the SIM orientation

What I found is that you need to use something with which to push the SIM in fully.

The SIM holder is spring loaded, so you need to push it in quite a bit before the spring latch catches and stops pushing the SIM out of the holder.
To remove the SIM, you push it in again to the release the spring, which will push it out again.

I found that a micro USB or a type C USB connector works really well to do this with. I could not get the SIM to stay in by just using my finger.

Hope this helps

Thank you @romihs for insight, but the SIM inserted properly using SIM Eject Tool. I tried 3 different SIMs with the same error :frowning:

Is there any way to connect using WiFi?

Hi krvarma

Can you try inserting a piece of paper when inserting the SIM card?, to kind of push the SIM card down towards the pins. Maybe the SIM cards is thinner than usual, or maybe the adapter is thicker than usual. We have seen that before, and it will cause issues if it’s too thick.

Can you try to inspect the pins in the reader, maybe they have been damaged by something. It may be hard to see when the device is inside the casing though.

Best regards
/Malte

@Malte I tried inserting a piece of paper but still no luck, the same error. I opened the case and checked the reader, from my inspection it is normal and seems nothing is damaged.

I am attaching a screenshot of the error I am getting.

Is there any way to connect using WiFi?

Another issue, I am not getting OBD aby information. I tried obd.status and obd,commands, both returns timeout error. Here is the screenshot.

Here is the screenshot of following commands

minionutil.last_logs
minionutil.last_errors

Not sure what to do.

Hi Krishnaraj

I have replied to your email.
Best regards
/Malte

@Malte Hi Malte I have a Autopi device that was working with the 4G SIM card a month ago, but now has the same issue described here - “[ERROR] No SIM card present”. I replaced a new SIM card and also made sure the orientation is correct, but still cannot get it work. The same SIM card works on phones or tablets with mobile data connection, Do you have any clue or solution for this kind of issue? Thanks.

1 Like

Hi @gw1018

Can you send an email to support@autopi.io with details about your issue?

Best regards
/Malte

I’m having the same issue. I’m not really sure why the SIM card isn’t being detected.

Did you guys try to clean the sim card, there is another post in the community with the same issue where it was solved by cleaning the sim card connectors. Use the search function here in community to find the discussion.

Br,
Mikael

Hi all,

Please also check the orientation of the SIM. The “triangle” end of the SIM needs to point out of the device as described in the getting started guide here:

best
Peter

I already sent mail to support@autopi.io, however worht mentioning here as well.
I have the exact same issue. Cleaned the SIM card and connector pins. tried different sim adapters but no luck.

What can be wrong?

Best regards,
Pravin