No gps data while driving and online through hotspot on my phone

autopi-dongle
#1

Subject of the issue

GPS doesn’t seem to work

Your environment

  • Version 2

Steps to reproduce

Drive around. I keep getting trips in the cloud that i am in south africa somewhere and i drove 0 km

Expected behaviour

Show correct location

Actual behaviour

Show wrong location (probebly no gps data)

Output of power.status command

If your issue is in any way related to the device shutting down or behaving in a unexpected way, please provide the output of the power.status command to help us diagnose the issue.

Run the command

power.status

in the terminal on local.autopi.io, and paste the result here.

Do’s & dont’s

  • Do not write your unit-id anywhere.
#2

I do have my device and phone paired via wifi sharing and do see inconsistent trip data.

Here is a summary of the issue I do see:

  1. Some trips have the start and end point, no data points between
  2. Some trips do not have the start and end reverse geocoded (display names for the locations)
  3. Some trips have no start and end, nor any data between

Most of my more recent trips experience issues. I recently turned on the Wifi sharing bit, maybe I will turn it back off again and see if that will help. Trip data is my most important use case for purchasing this device and I must have it reliable…

Cheers,

-Rob

#3

@rob.chartier

I don’t think it has to do with sharing wifi on the phone to get it online.
I did it to make sure it was connected to the internet so it could use agps but that did not help any
I think i get no gps data at all since i am allways in the ocean near south africa.
So perhaps someone knows how to test or activate the gps part of my dongle.
All other data seem to work fine.

Your issues might have to do with the dongle upside down.
It seems to work better when the logo faces up.

#4

Interesting. I must have missed the mounting instructions in the getting started guide, I believe i have my device upside down! Thanks!

I suspect your probably looking for some script to run on the device, which will output the current GPS data in realtime from the hardware. I havnt dug into my device just that far yet… with that said…

I have seen may GPS points with 0,0 come on my device as well.

Btw…if it is not overly obvious, the ocean near south africa will be lat of 0 and lon of 0, so your GPS just might not be getting a good fix with or without the AGPS data. I wonder if unplugging the device and/or at your next trip start, wait like 5+ minutes and allow the GPS to get a (better) fix before moving…?

A GPS cold fix may take some time, or the GPS itself might be busted…

#5

@rob.chartier

I think my gps is not working but i am looking for a good way to experiment with the autopi.
The main problem is that it is falling asleep after i park my car so it disconnects from my wifi.
Looking for a way to connect it from usb somehow but i think i need some screw drivers to open it to do so. I tried from a laptop to enter some help commands while someone else was driving and got all kind of errors while trying out some commands. Searching for some screw drivers now…

it is only day 3 since i have it so i am still learning.

Greetings from the netherlands…

#6

Greetings from Canada!

Have you tried to just sit in the car, idling, close enough to some wifi connection (maybe mobile tethered to your phone) and just SSH into the device? That way the device and connection will keep alive and will be stable…

#7

Ok i found out it was easy to change the sleep time settings from the cloud.
Got big warning sign when i pressed the advanced button but at least it is not falling asleep now before i can do anything.

first of all i dont know how to ssh to the autopi, When i try putty connect to the ip nr it got from my wireless it does’t seem to connect. However when i use terminal from the cloud it works ok so that’s fine for now.
I tried some ec2x commands but i don’t seem to pickup any sattelites somehow.
Perhaps i am looking in the wrong direction. This is all stil new to me.

results from command … ec2x.gnss_nmea_gsa
_stamp: ‘2019-08-15T18:23:23.689982’
vdop: null
hdop: null
fix_sat_count: 12
fix: 1D
pdop: null
fix_prns:

  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
    mode: A

results from command … ec2x.gnss_nmea_fix_stats
device number was here
return: null

hmm and now it fell asleep again.

going to test a bit more when it wakes up again.