No gps data while driving and online through hotspot on my phone

Subject of the issue

GPS doesn’t seem to work

Your environment

  • Version 2

Steps to reproduce

Drive around. I keep getting trips in the cloud that i am in south africa somewhere and i drove 0 km

Expected behaviour

Show correct location

Actual behaviour

Show wrong location (probebly no gps data)

Output of power.status command

If your issue is in any way related to the device shutting down or behaving in a unexpected way, please provide the output of the power.status command to help us diagnose the issue.

Run the command


in the terminal on, and paste the result here.

Do’s & dont’s

  • Do not write your unit-id anywhere.

I do have my device and phone paired via wifi sharing and do see inconsistent trip data.

Here is a summary of the issue I do see:

  1. Some trips have the start and end point, no data points between
  2. Some trips do not have the start and end reverse geocoded (display names for the locations)
  3. Some trips have no start and end, nor any data between

Most of my more recent trips experience issues. I recently turned on the Wifi sharing bit, maybe I will turn it back off again and see if that will help. Trip data is my most important use case for purchasing this device and I must have it reliable…




I don’t think it has to do with sharing wifi on the phone to get it online.
I did it to make sure it was connected to the internet so it could use agps but that did not help any
I think i get no gps data at all since i am allways in the ocean near south africa.
So perhaps someone knows how to test or activate the gps part of my dongle.
All other data seem to work fine.

Your issues might have to do with the dongle upside down.
It seems to work better when the logo faces up.

Interesting. I must have missed the mounting instructions in the getting started guide, I believe i have my device upside down! Thanks!

I suspect your probably looking for some script to run on the device, which will output the current GPS data in realtime from the hardware. I havnt dug into my device just that far yet… with that said…

I have seen may GPS points with 0,0 come on my device as well.

Btw…if it is not overly obvious, the ocean near south africa will be lat of 0 and lon of 0, so your GPS just might not be getting a good fix with or without the AGPS data. I wonder if unplugging the device and/or at your next trip start, wait like 5+ minutes and allow the GPS to get a (better) fix before moving…?

A GPS cold fix may take some time, or the GPS itself might be busted…


I think my gps is not working but i am looking for a good way to experiment with the autopi.
The main problem is that it is falling asleep after i park my car so it disconnects from my wifi.
Looking for a way to connect it from usb somehow but i think i need some screw drivers to open it to do so. I tried from a laptop to enter some help commands while someone else was driving and got all kind of errors while trying out some commands. Searching for some screw drivers now…

it is only day 3 since i have it so i am still learning.

Greetings from the netherlands…

Greetings from Canada!

Have you tried to just sit in the car, idling, close enough to some wifi connection (maybe mobile tethered to your phone) and just SSH into the device? That way the device and connection will keep alive and will be stable…

Ok i found out it was easy to change the sleep time settings from the cloud.
Got big warning sign when i pressed the advanced button but at least it is not falling asleep now before i can do anything.

first of all i dont know how to ssh to the autopi, When i try putty connect to the ip nr it got from my wireless it does’t seem to connect. However when i use terminal from the cloud it works ok so that’s fine for now.
I tried some ec2x commands but i don’t seem to pickup any sattelites somehow.
Perhaps i am looking in the wrong direction. This is all stil new to me.

results from command … ec2x.gnss_nmea_gsa
_stamp: ‘2019-08-15T18:23:23.689982’
vdop: null
hdop: null
fix_sat_count: 12
fix: 1D
pdop: null

  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
  • ‘’
    mode: A

results from command … ec2x.gnss_nmea_fix_stats
device number was here
return: null

hmm and now it fell asleep again.

going to test a bit more when it wakes up again.

Made a new sd card and had to wait till monday for it to start working because of the new minion_id.
Unfortunately i am still swimming in the middle of the ocean near south africa……
Anybody know the correct ec2x module settings for gps?
I think there must be a setting wrong in there because of it not getting a gps fix.
I have set sleep timer at 7200 seconds so that should be enough to get a fix somehow i think ?


The 2 antenna’s where delivered wrong way connected.
gps antenna was connected to main and main antenna was connected to gnss


1 Like

Hi Hans

Thumbs up for solving the issue, it seems like it’s one of those where the symptoms does not really point to anything obvious. If the GPS just didn’t work, it would be easier, but in this case where it responds, but with wrong positions, it’s quite tricky.

We have tried to make the device assembly as fool-proof as possible, ie. wire lengths should match the connectors etc, so that there is only one way to assemble everything, the correct way - we obviously failed in this case.
We have just improved our assembly instructions so that it does not happen in the future.

Sorry, that you had to spend time fixing this :slightly_frowning_face: and thank you for reporting the solution!

Best regards

No problem. Took me a while to find out wich antenna was gps and wich antenna was for the main connector. I could not find much info about how it should be connected or i didn’t search good enough but i assumed the square one must have been the gps antenna.
The cable lengts where glued in so that it could only be connected the wrong way so i had to pull the black one out of the glue to make it fit.

Now on to the next problem. Connect to wifi hotspots from ziggo where i need to use a certificate and username with password. i found some info in a ziggo forum to connect a raspberry to ziggo hotspots but didn’t get it working yet.

Also i am looking for a temporary solution to be able to connect with ssh over the wireless network where to the raspberry connected to. It only seems to work when connected to the hotspot of the dongle wich is very un handy when i am at home. It is more easy when it works over my wireless network instead of standing near the window to try connect with a laptop to the autopi.


Hans van der Haas


Because there was no activity for a while at the topic I close it. If your problem still exists or find another one, please do not hesitate to open a new topic or mail to

Best regards,