No contact with the cloud service

Subject of the issue

When locally ( logged in on the autopi, it reports it has connection to the cloud. reports that the cloud service does not have any connection to the autopi dongle.
I have checked and it is the right APN for my operator. There is no traffic from the dongle to the cloud service. The sim card (with subscription) works like a charm when i try it out in different phones.

Your environment

AutoPi Telematics Unit, CM4 - 4G/LTE Edition

Steps to reproduce


Expected behaviour

I would expect that the cloud service would report that it has connection to the dongle.

Actual behaviour

Locally logged in via wifi:

Logged in to the cloud service:

Output of power.status command

local user@Local device $ power.status
days: 0
seconds: 185
since_iso: ‘2023-04-20T13:18:46.472476’
since_t: 1681996726
time: ‘0:3’
users: 1
level: 100
state: discharging
voltage: 12.6
current_state: ‘on’
down: none
up: ‘on’
down: none
up: plug
sleep_interval: 0
version: ‘4.0’
volt_factor: 0.993
duration: 240000
threshold: 12.2
difference: 0.5
period: 1000
duration: 3000
threshold: 13.2

We’re you able to make any progress?
It seems I have the same issue with a brand new CM4 unit, connected via LTE.

Sorry, no progress. Tried to flash the autopi from a windows machine but I could not get it to recognize the usb connection. Tried the right drivers and reinstalled everything. The autopi automatic update function does not work. My next step is to try to reinstall the os from a Linux machine.

1 Like


I recommend that you reach out to, they can definately assist you.


I’m in the same situation. Mine had a failed update so re-flashed. It says it’s connected to the cloud but doesn’t show up. (yes, I’ve accepted the new key after the flash)

Sent an email to support. I will post the solution if it works.

Got the following solution from support that worked:


Thank you for reaching out to support.

It seems like an MTU issue. It’s a quick fix. Connect to your device hotspot and login to “”. From there run the these 2 following commands.

$ grains.set qmi:mtu 1430

$ state.sls network.wwan.qmi.config

Once the MTU is set. Please reboot your device and check the status of the device in cloud again.

Hope this helps.

1 Like

Did this work for you? Mine’s still not connecting.

The solution from the support worked perfectly for me.
I suggest that you drop them an email.


This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.