My autopi need a better cellular antenna

#21

You are in Groenland ? Lol ;).

#22

This is what i have
it is still good

qmi.cell_info

"[/dev/cdc-wdm0] Successfully got cell location info\nIntrafrequency LTE Info\n\tUE In Idle: ‘no’\n\tPLMN: ‘20801’\n\tTracking Area Code: ‘194’\n\tGlobal Cell

ID: ‘10031107’\n\tEUTRA Absolute RF Channel Number: ‘6400’ (E-UTRA band 20: 800 DD)\n\tServing Cell ID: ‘274’\n\tCell [0]:\n\t\tPhysical Cell ID: ‘274’\n\t\t

RSRQ: ‘-11.0’ dB\n\t\tRSRP: ‘-78.9’ dBm\n\t\tRSSI: ‘-51.0’ dBm\n\tCell [1]:\n\t\tPhysical Cell ID: ‘285’\n\t\tRSRQ: ‘-18.9’ dB\n\t\tRSRP: ‘-86.7’ dBm\n\t\tRSS

I: ‘-59.2’ dBm\nInterfrequency LTE Info\n\tUE In Idle: ‘no’\nLTE Info Neighboring GSM\n\tUE In Idle: ‘no’\nLTE Info Neighboring WCDMA\n\tUE In Idle: ‘no’"

and autopi become Superautopi, :joy:




5 Likes
#23

Your solution is magnificent, I will do something similar.

#24

My autopi does not communicate in GSM (2G).
I put it on the roof of a car in a place where cell phones call perfectly.
I tried calling and sending a text message but he is offline.
Is it possible that my dongle is defective?
what should i do? In my house it only takes the 2G signal (GSM, EDGE) 900 MHz (Band 8)

#25

this picture is worth a thousand words,
a good GSM but autopi signal does not receive calls and SMS, completely OFFLINE.

#26

so that why you should try to put external antenna.
edge is very slow, but sms should be ok
but for me, dongle need 3g minimum to be online, because if it is too slow, it is need more than 30 seconde, and timeout is 30.
i am not an expert, but 2G is only for sms in 2019. for connexion, it is too slow because every thing is more eavy (in kb) than before.
I think best way for you is configure the wifi (in the autopi) when you are at home.
so, when you come back home, wifi will be on automatiquely and then autopi will be online.
and when you drive and go outside, autopi will use gsm automatiquely because he can’t connect to the home wifi.
maybe it is the good way for you
also antenna will be great, to have best gsm reception, because you seem live in Groenland , lol

#27

I don’t want to work on the dongle through GSM communication. I would only be happy to send an SMS to turn it on remotely. Because in my house there is excellent WI-FI coverage with mid-range broadband. But when autopi is off I can’t do anything to turn it on.

#28

Ok. So, I saw topic how to wake up by sms but I don’t know how it work.
Only there is an option on autopi you should turn on
And edge (2g) should work in that case. If it is just to wake up autopi.

#29

Maybe I did not say it clear enough. although the GSM signal is present, Autopi does not detect it. he does not receive text messages. and that’s the problem. despite the right configuration, it seems to never connect to the 2g network and text messages are not delivered. so I can’t turn it on.

#30

Ok.
My English is very bad sorry.
Maybe try to send mail at autopi team

#31

I’m doing a lot of testing, I’ve mounted two new antennas. I discovered that the rear window of my car greatly reduces the signal because it is equipped with defrosting resistors.

2 Likes
#32

Nuovi valori a casa mi a dove è installato un GSM repeater (inside the house, external power supply mode)

local user@Local device $ qmi.system_info

“[/dev/cdc-wdm0] Successfully got system info:\n\tGSM service:\n\t\tStatus: ‘available’\n\t\tTrue Status: ‘available’\n\t\tPreferred data path: ‘no’\n\t\tDomain: ‘cs-ps’\n\t\tService capability: ‘cs-ps’\n\t\tRoaming sta
tus: ‘off’\n\t\tForbidden: ‘no’\n\t\tLocation Area Code: ‘25295’\n\t\tCell ID: ‘26890’\n\t\tMCC: ‘222’\n\t\tMNC: ‘01’\n\t\tE-GPRS supported: ‘yes’\n\t\tDual Transfer Mode supported: ‘no’\n\t\tCell broadcast support: ’
on’\n\t\tCall barring status (CS): ‘all-calls’\n\t\tCall barring status (PS): ‘all-calls’\n\t\tCipher Domain: ‘none’\n\tWCDMA service:\n\t\tStatus: ‘none’\n\t\tTrue Status: ‘none’\n\t\tPreferred data path: ‘no’\n\tLTE
service:\n\t\tStatus: ‘none’\n\t\tTrue Status: ‘none’\n\t\tPreferred data path: ‘no’\n\tSIM reject info: ‘available’”

local user@Local device $ qmi.cell_info

“[/dev/cdc-wdm0] Successfully got cell location info\nGERAN Info\n\tCell ID: ‘26890’\n\tPLMN: ‘22201’\n\tLocation Area Code: ‘25295’\n\tGERAN Absolute RF Channel Number: ‘24’\n\tBase Station Identity Code: ‘21’\n\tTimin
g Advance: ‘unavailable’\n\tRX Level: -56 dBm > level > -55 dBm (‘55’)\n\tCell [0]:\n\t\tCell ID: ‘26889’\n\t\tPLMN: ‘22201’\n\t\tLocation Area Code: ‘25295’\n\t\tGERAN Absolute RF Channel Number: ‘22’\n\t\tBase Station
Identity Code: ‘20’\n\t\tRX Level: -74 dBm > level > -73 dBm (‘37’)\n\tCell [1]:\n\t\tCell ID: ‘26802’\n\t\tPLMN: ‘22201’\n\t\tLocation Area Code: ‘25295’\n\t\tGERAN Absolute RF Channel Number: ‘1003’\n\t\tBase Station
Identity Code: ‘19’\n\t\tRX Level: -84 dBm > level > -83 dBm (‘27’)”

#33

local user@Local device $ cmd.run ‘qmi-manager up’ _timeout=120

“[/dev/cdc-wdm0] Device model retrieved:\n\tModel: ‘QUECTEL Mobile Broadband Module’\nLoading profile at /etc/qmi-network.conf…\n APN: ibox.tim.it\n APN user: unset\n APN password: unset\n IP type: 4\n
qmi-proxy: no\nLoading previous state from /tmp/qmi-network-state-cdc-wdm0…\n Previous CID: 20\n Previous PDH: 2265652592\nerror: cannot re-start network, PDH already exists\n[ERROR] Failed to start QMI network
connection - error: cannot re-start network, PDH already exists”

#34

new antennas, but always at my house:

giovanni@PandaCross $ qmi.system_info

“[/dev/cdc-wdm0] Successfully got system info:\n\tGSM service:\n\t\tStatus: ‘available’\n\t\tTrue Status: ‘available’\n\t\tPreferred data path: ‘no’\n
\t\tDomain: ‘cs-ps’\n\t\tService capability: ‘cs-ps’\n\t\tRoaming status: ‘off’\n\t\tForbidden: ‘no’\n\t\tLocation Area Code: ‘25295’\n\t\tCell ID:
‘26890’\n\t\tMCC: ‘222’\n\t\tMNC: ‘01’\n\t\tE-GPRS supported: ‘yes’\n\t\tDual Transfer Mode supported: ‘no’\n\t\tCell broadcast support: ‘on’\n\t\tC
all barring status (CS): ‘all-calls’\n\t\tCall barring status (PS): ‘all-calls’\n\t\tCipher Domain: ‘none’\n\tWCDMA service:\n\t\tStatus: ‘none’\n\t
\tTrue Status: ‘none’\n\t\tPreferred data path: ‘no’\n\tLTE service:\n\t\tStatus: ‘none’\n\t\tTrue Status: ‘none’\n\t\tPreferred data path: ‘no’\n\t
SIM reject info: ‘available’”

giovanni@PandaCross $ qmi.cell_info

“[/dev/cdc-wdm0] Successfully got cell location info\nGERAN Info\n\tCell ID: ‘26890’\n\tPLMN: ‘22201’\n\tLocation Area Code: ‘25295’\n\tGERAN Absolute
RF Channel Number: ‘24’\n\tBase Station Identity Code: ‘21’\n\tTiming Advance: ‘unavailable’\n\tRX Level: -82 dBm > level > -81 dBm (‘29’)\n\tCell
[0]:\n\t\tCell ID: ‘26889’\n\t\tPLMN: ‘22201’\n\t\tLocation Area Code: ‘25295’\n\t\tGERAN Absolute RF Channel Number: ‘22’\n\t\tBase Station Identity
Code: ‘20’\n\t\tRX Level: -97 dBm > level > -96 dBm (‘14’)\n\tCell [1]:\n\t\tCell ID: ‘26803’\n\t\tPLMN: ‘22201’\n\t\tLocation Area Code: ‘25295’\n\t
tGERAN Absolute RF Channel Number: ‘1000’\n\t\tBase Station Identity Code: ‘19’\n\t\tRX Level: -99 dBm > level > -98 dBm (‘12’)”

#35

Hi, can please someone direct me to the best antenna for LTE and GPS to add to my autopi? I park in underground garage where the signal is too low. Even for my iPhone I am getting EDGE… Or do you think external antenna wouldn’t help?

Thank you