Is it possible to change Autopi’s hotspot password?

I want to use the Autopi’s Internet connection on my iPhone via the hotspot. I assume this is possible. I can see the hotspot’s SSID and initiate a connection from my iPhone. However, no matter what password I set up in, the phone tells me that the password is incorrect.

I don’t think I’m making typing errors. I generate the password in 1Password and copy it into Advanced > Settings > Wifi before saving and waiting for confirmation that the wifi settings have been successfully saved. When I initiate the connection to the hotspot, I copy the password from 1Password.

I have tried long (32 character), short (8 character) and the default passwords. I always get the same error (incorrect password).

I have tried using a different iPhone. Exactly the same behaviour.

I have added the MAC addresses of the iPhones I tested with to the client allow lists. I have set up a range in the DHCP settings. However, if the password is being rejected as incorrect, it isn’t getting that far.

Any ideas about what is going on and how to fix it?

I found the problem. The “private wifi address” setting on the iPhone was selected. I would have found it sooner if the Apple error message had been “unknown device” or something other than “incorrect password”. Perhaps hostapd, which handles the logins to the hotspot doesn’t make a distinction?

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.