Ioniq BEV 28 kWh; staying awake, charging messages, CO2 usage


What I did: Copy the script in “Advanced / Custom code”
Then, Created a Logger PID in “Car Explorer / loggers”
Finally created a Widget based on the created PID

Not sure what you mean, “from custom code”. The PID that you select in the loggers are from your library, not from any custom code.
The easiest is just to copy from the community library (filtering on the right car) into my library (“Add to my library” from the library PID). It is also possible to add your own.
Just some screenshot samples (SOC Display:)

16 PM

16 PM 001

17 PM

17 PM 001

1 Like

What power setting in the dongle you use now?
Regard Jörgen

At the moment there is a new version not sure uf that has any effect and needs some changes to work properly. I cannot update my dongle for some reason, support is looking at it.
These are my settings now:
For supress sleep (cannot be seen in the screenshot)
12.6 and 12.50, see screenshots.
33 PM 34 PM 001 34 PM image

Thankyou very much for a lovely work :slight_smile:
I will try to update again .
But i have the same problem with my Autopi in the car that the modem not working that it should.
Autopi is online but not send or get data.
Sometime it can be fo many days that is not work.
This has been since the first time i get the dongle , but they have never solve the problem.

1 Like


From what i have underatood the internal antenna is not that great.
I had it below my left foot, but then I tried it with the dongle in my knee :slight_smile: , just in front of the steering wheel and in the door, no real difference.

Now I have ordered an antenna and cable, I should get it this week, I think that will do the trick.

It never fails to send Telegram messages, so my guess is that it is the LTE connection that is failing and it is working only on 2 or 3G so when there is more data to send it will not work properly unless it has a 4G connection.

1 Like

Hi Anders
Yes i think it bad antenna to.
But in my case when it works it works fine. But some days it not work at all at the same route i do daily.
And that include all data , telegram messages to.
And it can be for days sometime

1 Like

FYI I reverted back to the script to keep it awake for the moment, the power setting caused trouble when updating the dongle, it couldn’t do the install. Let’s see if there is anything new in the update that can be used to controll power.

1 Like

After reflashing my device and update to the new software , anything is a mess .
Ita was not good before either and have a very long mail conversation to support , but no solution.
How is it working for you now after update?
Regard Jörgen

Hi Jörgen,
I had some issues updating but it finally went through with some support. I had to force sleep it.
Now with the new version I got the tip from support how to configure it, I used option 1b.
I set it up day before yesterday and so far it has worked properly. I did it when charging so that it wouldn’t go to sleep for some reason while configuring.
I made the logger first (running every two minutes), waited some minutes to be sure that it had run a couple of times.
Then I disable the job for the sleep postponement and finally configured the power settings.

Here is the link to how to configure the logger and power settings:

1 Like

Hi again Jörgen,
New update after changing the configuration; Works like a charm now with the latest (and the right configuration), has been running now for almost a week. Good work by the developers!
I decreased the time to got to sleep to three minutes (delay 180 seconds) as the critical level is reached before it goes to sleep for the Ioniq, don.t know about other cars.

Thats sounds lovely :slight_smile: I have tried to with the new configuration.
Very good work AndersO , with all help and support :smiley:

But still have problem with the LTE that not work at all.
I will try anoter provider this weekend and see how it works.
But i must say i feel very tired of my autopi now , because it has been problem and a experiment since the first day i get it.

HI Anders
Now i try a new provider and LTE is working better.
It must been something with the APN that not work good with my other provider.

I have now tried to set up power cycle for the Ionq , but tried 1A in your link you send me.
I find a RPM Pid in the library that i use in daschboard to , but i am not sure it was working so good in the setup.

What setup you use in 1B that make it work?

Regard Jörgen

Hi Jörgen,
I made a copy (PIDs cannot be reused) of a PID that i know returns at all times when it is connected (SOC), but what i understand you can use any PID.
See screenshot:
36 PM 001
I made a logger on it (important to set the communication_event)
36 PM
And these are the power settings:
36 PM 002
37 PM 001

I can’t update my dongle, a new version is on queue but nothing works. I’ve tried to use minion update but with the same result. Someone can I help me? Thanks

Hi, I had an issue updatinga as well since the dongle didnt go to sleep at all but shut down on critical voltage. I got the below from support (make sure that the dongle is on e.g. car running or charging):

From support: I am not exactly sure how your device is configured, but the update process is started when the device sleeps, and I can see on the device that it “knows” about the new update, it just haven’t started the process yet. The events from your device does not show any sleep events, ie. the current configuration might make it so that the device does not sleep, but instead goes to hibernate, and in that case, it does not start the update.

The easiest way to make it update might be to send the following command to make it go to sleep, at which point it will first apply the update, and then go to sleep.

power.sleep confirm=true

It will wake up after 1 minute as that’s the default interval, but you can set it to another value by using the argument


You can see all the arguments here:

Best regards, Support

1 Like

Tanks, but I have error timeout has occurred


All commands give me error timeout

Hi, I think it is because it goes to sleep, it did it for me as well but came back after some time after it had updated.