Hostapd broken after update/upgrade



During process of following steps to get touch screen working (Link: RPI3 B+ with Touchscreen running UI ) appears the my wireless AP has disappeared. Any one else run into this issue with hostapd?


Can you elaborate at what stage you have the issue? i.e. what commands did you run and at what point did it fail?
I have seen some issues with 4G modem failing to connect (reported support ticket in process) and Wifi access point failing to re initialize on some reboots when updating to the last versions of AutoPi.
But the issue seems to be with AutoPi not the Linux (apt-get update & upgrade).

Also if you find any reason and solution, please update this post also to my post (the link you posted in your comment here).



During apt-get upgrade is when failure happened.
Half way into upgrade, AutoPi sleep mysteriously kicked in. After wakeup, had to do sudo dpkg --configure -a to get restarted with upgrade. Message popped up about a conf file version and did I want new version or stay with existing. I chose existing (or N to modifying file). AP disappeared right after that.

I’m thinking I need to copy /etc/salt/pki/minion files and start with fresh install. But wanted to see if it was easy fix.
Steps I have taken already are shown in link:
Used these steps to try and get AP working again. All other functions appear to work, except AP. Unfortunately AP is only way to connect to AutoPi remotely.


I had same issues before I started setting the standard power-off settings to longer time-frame before updates. You can also manually cancel the automated shutdown when it is advertised by the system by calling “shutdown -c” in ssh. But requires you to have a separate ssh session running.

Sounds like the issue is where you “I chose existing (or N to modifying file).” . As I did not have this issue and I have done the update from fresh clone several times but always selected “yes” to update to new configurations.

Guessing quickest fix is to start from fresh SD clone and re-do the updates with one of the options I mentioned.



I tried the update again and it appears the same result. Grabbed a screen shot of message regarding cause.

After getting above message, AP stops responding and only option is direct connection to AutoPi/RPi3 dongle via HDMI and Keyboard-Mouse.

Again, this is following steps in RPI3 B+ with Touchscreen running UI

sudo apt-get update <- this works fine.
sudo apt-get upgrade <- shortly in message above is shown, AP breaks.


Hi Rich

It seems that a recent update of hostapd has made some changes that causes the hotspot/ap to no longer work.

But i’m not sure what causes it, if it’s the configuration file, maybe some settings has been added or changed, and the config file that we use is missing or is using deprecated/removed settings.

If found this thread, that has a few ideas, and also maybe a version of hostapd that still works.
So the short-term solution could be to lock the version of the service to a version that works.

To pin/hold the version

apt-mark hold hostapd

To unpin

apt-mark unhold hostapd

Can you try the above solution, and see if that changes anything?

Best regards

1 Like

That did the trick @Malte.
NOTE: During this procedure, I am connected to ODB power source. When connected to ODB Power source, it is vital that ‘$ autopi power.sleep_timer enable=false’ must be run to stop AutoPi from going to sleep during any step. Disable sleep timer after each reboot/restart. I would not recommend disabling sleep timer permanently because you will wake up to a dead car battery one day.

Starting from a fresh clone, I copied my Minion files to the SD as described in Reflashing your device post.
Next step, fire up AutoPi and make success network connection, log into AutoPi Cloud to Sync and push updates. This sometimes takes a couple connections to get Sync and Updates.
At this point, I follow the thread/link you provided above. Since I had not done update/upgrade yet, I just did the ‘apt-get mark hostapd’ command to lock in the hostapd version.
Continuing on with steps in RPI3 B+ with Touchscreen running UI post to update, upgrade and install mods, was completely successful and AP did not break.

At this point, I have a functioning AutoPi with WiFi and 4G connections and has a functioning AP. :checkered_flag: Connecting to touchscreen works also. This portion is done :clap:, setting up display and web is not too challenging.

I still have a lot to learn about Linux, RPi and much of the programming around them. Thanks for help.


RPI3 B+ with Touchscreen running UI

If you Remove the Space on the end of the deamon args or remove the high comma in the /etc/defaults/hostapd everything works like bevor.