Getting started with your DIY Edition


#1

Congratulations on your AutoPi Dongle DiY Edition

We are sure that you have great plans for how you want to use your AutoPi Dongle DiY edition, either with a Raspberry Pi Zero or with a Rapsberry Pi 3 using the AutoPi RPi3 Adapter.

Connecting the Raspberry Pi

Here is a small guide to connecting a RPi Zero to you AutoPi.

  1. Get your Raspberry Pi Zero and the 40 pin header that came with your AutoPi:

  2. Solder the pin header to the Raspberry Pi:

  3. Connect the flat micro USB cable that came with your AutoPi. One end needs to be connected to the vertical USB connector on the AutoPi board and the other end needs to be conencted to the USB out on the Raspberry Pi:

  4. Mount the Raspberry Pi on the AutoPi. Use the screws that came with your AutoPi, to fasten the Raspberry Pi:

Connecting to the Cloud

Should you want to use the AutoPi Cloud, then you can use this image found here to setup your device:

TIP: Etcher can write the compressed image directly to the SD card). We recommend using a Class 10 SD card with minimum 8Gb storage
The image has been optimized for Raspberry Pi Zero.

Logging in to the device
The device is initially configured to use the following credentials

WiFI
SSID: AutoPi-Initial
Password: autopi2018

SSH
User: pi
Password: autopi2018

You should consider changing these to something else once you get up and running.

Getting access to the cloud
To get your device on the AutoPi Cloud you need to get an ID for your device, see the below steps.

  1. Ensure that the etc/salt/minion config file has the master specified. Look for the line

    master: hub01.autopi.io
    
  2. Remember to configure the APN settings.

  3. Write to support with your unit_id (Find by logging into the local hotspot, or see file /etc/salt/minion_id) and ask (support@autopi.io) for it to be approved in the system (the dongle needs to be online at least once before this can be done)

Please note: The AutoPi always needs power through the OBD connector, to function properly. Powering the board through the micro usb power plug on the Raspberry Pi could damage your board. If you need to test the AutoPi in a lab environment, we encourage you to get the OBD power connector from the shop.


DIY Edition Password
DIY Edition Registration
Bring your own Raspbian?
#2

#3

ā€œ1. Add master: hub01.autopi.io 9 to the etc/minion config file.ā€
I do not find a /etc/minion config file. Do I create /etc/minion.conf with that single line in it?

Figured it out. Should be "etc/salt/minion config file. Add the line

master:hub01.autopi.io

on a separate line. I added it at the end. Still canā€™t seem to ping anything. Do I have to have an active sim card installed? Can I not get the autopi online via wifi?

When I configure my home wifi network via wpa_supplicant.conf, it shows as working, but fails to get Internet access, nor can I ping it from anything else.


#4

Hi @thenrie

Ahh yes you are right. Iā€™ve updated the guide with the correct file path to the minion config file.

Now to your question. You shouldnā€™t need to have a SIM inserted to get it online. If you use the latest image, then you should be able to setup the WiFi using the local hotspot. You can get the latest image here:

There is a graphical GUI for setting it up. Just log on to the hotspot (with your phone or another device) using the credential from the guide. Once you are connected to the hotspot, open up a browser and go to local.autopi.io, this will open the settings page for the AutoPi, where you can configure the WiFi you want the device to connect to.

Once you are online and can ā€œping googleā€, then just send your unit ID to support@autopi.io, and they will be able to register the ID to your account. The ID can be found in the local GUI in the top of the screen.

best
Peter


#5

Ahh, nice. Thanks.

By the way, the line ā€œmaster:hub01.autopi.ioā€ is already written in the newest autopi-core 05.10.18 (v1.1) linked above, so step 1 of the guide is already handled.

Thanks again.


#6

The hotspot is not coming up under the new autopi-core (1.1) image. I noticed the new core brings up the interface as uap0, rather than wlan0 as under the previous iteration. The ssid is still set as AutoPi-Initial, but it does not show up on my computer as an available network.

Also, raspi-config is now disabled.

I noticed in the bootup that ā€œwifi is disabled if country not setā€. With the nohook wpa_supplicant set in dhcpcd.conf, does that not bypass the country setting? Could that be the issue?

Update: I commented out the nohook command on uap0 in /etc/dhcpcd.conf and the hotspot showed up. I set up my wifi connection on the local gui, but still could not get a connection to my wifi network. I commented out the nohook command on wlan0 in /etc/dhcpcd.conf as well and was able to get an Internet connection through my wifi network.

Cool!

Sent the dongle key to support. Looking forward to seeing what I can do with it.

I just did the apt-get update/upgrade thing to get the full Raspbian Stretch on the rpi3B, to see what else I can do alongside the autopi. Took forever, but everything still works.


#7

Hi @Thenrie

We have just tested with the same image, but with a rpi zero, and we canā€™t seem to reproduce the issues.
The new image contains changes to the way wifi and the hotspot in handled, so the changes you mention, including the addition of the nohook commands, as they ensure that the different services start up in the right order.
We have made no changes to the raspi-config tool, and it works when we tested it just now.

The country should be set, so that should not be an issue.

As i said above, I have just tested the image and everything seems to be in order. But, as i said, I tested it on a rpi zero, so I will do the same test with a rpi3 just to make sure, I will get back to you if i find anything :slight_smile:

I have a few questions though

  • When did you update raspbian stretch via apt-get? Before or after it stopped working?
  • Have you tried rebooting the device to see if that fixes the hotspot not appearing?

Best regards
/Malte


#8

Hmmm. Seems I may have outsmarted myself.

I just looked again at /etc/dhcpcd.conf and find the nohook on both uap0 and wlan0 uncommented (nohook effective). I must have gone back again and undid what I tried before. Anyway, both the hotspot and wifi connection are working.

I updated/upgraded Stretch after getting the hotspot and wifi connection working. Took forever!

Raspi-config is also working, except for setting the country. Apparently your image has locked out wpa_supplicant from raspi-config. It gives the message that raspi-config cannot communicate with wpa_supplicant. Resetting the country code has to be done manually. You have it pre-set for GB, so I manually reset it to US. I also reset the other locale settings to US. If I donā€™t ensure the locales and keyboards are correct, it really screws with passwords.

I started the install of Navit last night, but didnā€™t get it finished. Now, for some reason, my Rpi/autopi will boot up, connect, then shuts itself down after about 3 minutes. Iā€™ll have to look at the logs to see whatā€™s going on. But that will be another thread in another forumā€¦

Anyway, your new image (1.1) is working as advertised. Donā€™t know why it took so much fiddling, since I apparently changed everything back to its original state to get it working. My brain must have been fried when I composed the post from last night. Sorry.

Tony


#9

OK. Now Iā€™m experiencing another issue.
After booting up, the last three lines in the boot log are:

[#[0;32m OK #[0m] Started /etc/rc.local Compatibility.
Starting Hold until boot process finishes upā€¦
Starting Terminate Plymouth Boot Screenā€¦

it then shows the login lines and allows a login, but after about a minute Plymouth initiates a controlled shutdown. If I login, I can execute commands and everything functions, but within about a minute it will shutdown. It will shutdown whether I login or not. It is a controlled shutdown in which it logs the shutdown processes. It starts by shutting down the IEEE management daemon, then wpa_supplicant.

After doing a little research in the Internet, it appears Plymouth is the problem, but nobody knows why it happens nor has anyone found a solution, at least nobody I have found so far. Canā€™t really uninstall Plymouth, because it is a dependency for other programs.

This just started today. I reflashed the SD card with the new image. Same result. I flashed a different card with the new image. Same result. Iā€™m pretty certain this is not a hardware issue, as everything works, including the hotspot, before the shutdown is initiated.

Any help would be appreciatedā€¦again.

Tony


#10

I decided to try installing the full Raspbian and see what happens. No issues. Ran perfectly.

Thought that maybe the autopi image I am using is corrupted, so I re-downloaded the 05.10.18 image and reflashed my sd card. No change, shutdown after about three minutes. The time gets shorter every time it shuts down.

I believe the issue may stem from my expanding the fs using the raspi-config utility. I am using a 32G sd card, so I expanded it. When I reflashed the image on it, the first time it booted, I got error messages in the bootup process, however, it indicated adjustments had been made and partitions deleted, filesystem expanded to fill the space, restarted itself, then bootedā€¦then shut down.

I re-formatted the SD card as FAT32 MBR and reflashed it with a fresh 05.10.18 image, hoping the format process will completely wipe all partitions and data and start clean.

Getting a message during boot: resi-filesystem to fill partition,
then another that indicates a process to start salt minion.

Salt minion failed to start. I started it via systemctl. Rebooted. Salt started this time. System has stayed up. I now get the hotspot, but no wifi connection. systemctl list-units indicates all units have loaded successfully, except wpa-manager.service. It loaded but failed. I have tried without success to start it via systemctl and manually.

Have rebooted several times. Same result. Have hotspot, no wifi connection, local gui does not see my wifi networks.

It seems strange to me that when I got everything working last night, I looked at /etc/wpa_supplicant/wpa_supplicant.conf and setting up the wifi by use of the local.autopi.io gui set the network settings up in wpa_supplicant.conf just the same way I do it manually. However, now the wpa-manager.service will not even load. It seems that something in your image blocks or disables wpa_supplicant. I canā€™t find anything that takes its place.

Done for the night.

Hope you can help.

Tony

The system stayed up.


#11

Youā€™re not going to believe thisā€¦well, maybe you will.

I have no idea about the problem with the system shutting down, but I got that fixed, as noted above.

The problem with getting the hotspot up, but the local.autopi.io gui not finding my networks, was entirely an issue with Google Chrome. Just by chance I decided to try Safari (Iā€™m an Apple guy) and vioila! first time! Apparently, something in Chrome was not allowing the autopi gui see my networks, so I could not configure them. Safari had no such problem. Everything operating with no changes to your 05.10.18 image, other than having to manually start Salt, as indicated above.

Starting update/upgrade of Stretch again. Iā€™ll keep you posted if anything bad happens.

All is well in the world again. Iā€™m back up.


#12

Here we go again.

After update/upgrade of Stretch, and after installing Navit from scratch, the unit is again shutting down. Apparently the full Raspbian is not going to play well with the autopi image.pi


#13

Hmmm. So, I re-flashed a 16G sd card with the 05.10.18 image, a card that previously had been flashed with Raspbian Stretch. It should be clean after the flash with etcher, when I re-flashed it with the autopi image. The system is shutting down as indicated above. I believe the issue is that the boot process is not completing for some reason. It may have something to do with the fact that I expand the file system (using raspi-config utility) after bootup, to utilize the cardā€™s entire capacity for the fs. I did not do that this time, but I did it when it had Raspbian installed and during the first boot with autopi 1.1, it causes an error code during boot, but it resolves itself by deleting a partition and expandin the fs and restarting automatically. Still, somehow, auto shutdown is being triggered. Again, it is a controlled shutdown process. You should not have any problem duplicating this issue.

I should mention that while the system is up, the hotspot and wifi are working and I can connect to the dongle locally and ping google.com. But, it still shuts down within a minute or so.

Fact is, this is a bug that should be addressed. Sorry Iā€™m not good enough with coding to know what to do.

Tony

Below is my boot.log:

/var/log/boot.log

[#[0;32m OK #[0m] Started Show Plymouth Boot Screen.
[#[0;32m OK #[0m] Reached target Encrypted Volumes.
[#[0;32m OK #[0m] Started Forward Password Requests to Plymouth Directory Watch.
[#[0;32m OK #[0m] Found device /dev/disk/by-partuuid/9abf5796-01.
Starting File System Check on /dev/disk/by-partuuid/9abf5796-01ā€¦
[#[0;32m OK #[0m] Created slice system-systemd\x2dbacklight.slice.
Starting Load/Save Screen Backlight Brightness of backlight:rpi_backlightā€¦
[#[0;32m OK #[0m] Listening on Load/Save RF Kill Switch Status /dev/rfkill Watch.
[#[0;32m OK #[0m] Reached target Sound Card.
[#[0;32m OK #[0m] Started Load/Save Screen Backlight Brightness of backlight:rpi_backlight.
[#[0;32m OK #[0m] Started File System Check on /dev/disk/by-partuuid/9abf5796-01.
Mounting /bootā€¦
[#[0;32m OK #[0m] Mounted /boot.
[#[0;32m OK #[0m] Reached target Local File Systems.
Starting netfilter persistent configurationā€¦
Starting Create Volatile Files and Directoriesā€¦
Starting Preprocess NFS configurationā€¦
Starting Tell Plymouth To Write Out Runtime Dataā€¦
[#[0;32m OK #[0m] Started Tell Plymouth To Write Out Runtime Data.
[#[0;32m OK #[0m] Started Preprocess NFS configuration.
[#[0;32m OK #[0m] Reached target NFS client services.
[#[0;32m OK #[0m] Reached target Remote File Systems (Pre).
[#[0;32m OK #[0m] Reached target Remote File Systems.
[#[0;32m OK #[0m] Started Create Volatile Files and Directories.
Starting Network Time Synchronizationā€¦
Starting Update UTMP about System Boot/Shutdownā€¦
[#[0;32m OK #[0m] Started Update UTMP about System Boot/Shutdown.
[#[0;32m OK #[0m] Started Network Time Synchronization.
[#[0;32m OK #[0m] Reached target System Initialization.
[#[0;32m OK #[0m] Listening on D-Bus System Message Bus Socket.
[#[0;32m OK #[0m] Started CUPS Scheduler.
[#[0;32m OK #[0m] Reached target Paths.
[#[0;32m OK #[0m] Listening on CUPS Scheduler.
[#[0;32m OK #[0m] Listening on GPS (Global Positioning System) Daemon Sockets.
[#[0;32m OK #[0m] Reached target Sockets.
[#[0;32m OK #[0m] Reached target Basic System.
[#[0;32m OK #[0m] Started CUPS Scheduler.
[#[0;32m OK #[0m] Started Make remote CUPS printers available locally.
Starting dhcpcd on all interfacesā€¦
Starting Login Serviceā€¦
Starting The Salt Minionā€¦
[#[0;32m OK #[0m] Started D-Bus System Message Bus.
Starting Disable WiFi if country not setā€¦
[#[0;32m OK #[0m] Started Regular background program processing daemon.
Starting System Logging Serviceā€¦
[#[0;32m OK #[0m] Started Daily Cleanup of Temporary Directories.
[#[0;32m OK #[0m] Reached target System Time Synchronized.
[#[0;32m OK #[0m] Started Daily apt download activities.
[#[0;32m OK #[0m] Started Daily apt upgrade and clean activities.
[#[0;32m OK #[0m] Reached target Timers.
[#[0;32m OK #[0m] Started dhcpcd on all interfaces.
[#[0;32m OK #[0m] Started Login Service.
[#[0;32m OK #[0m] Started Disable WiFi if country not set.
Starting Load/Save RF Kill Switch Statusā€¦
[#[0;32m OK #[0m] Started Load/Save RF Kill Switch Status.
[#[0;32m OK #[0m] Started netfilter persistent configuration.
[#[0;32m OK #[0m] Started System Logging Service.
[#[0;32m OK #[0m] Started The Salt Minion.
[#[0;32m OK #[0m] Reached target Network (Pre).
Starting Raise network interfacesā€¦
[#[0;32m OK #[0m] Started Raise network interfaces.
[#[0;32m OK #[0m] Reached target Network.
Starting Permit User Sessionsā€¦
Starting OpenBSD Secure Shell serverā€¦
Starting Advanced key-value storeā€¦
Starting Lighttpd Daemonā€¦
[#[0;32m OK #[0m] Reached target Network is Online.
Starting LSB: Advanced IEEE 802.11 management daemonā€¦
Starting /etc/rc.local Compatibilityā€¦
Starting dnsmasq - A lightweight DHCP and caching DNS serverā€¦
[#[0;32m OK #[0m] Started VNC Server in Service Mode daemon.
[#[0;32m OK #[0m] Started QMI Network Connection Manager Service.
[#[0;32m OK #[0m] Started Permit User Sessions.
[#[0;32m OK #[0m] Started /etc/rc.local Compatibility.
Starting Hold until boot process finishes upā€¦
Starting Terminate Plymouth Boot Screenā€¦


#14

Hi Tony

Because you are using a RPi3 (which is faster than the Zero), an underlying service is failing its update to an external component ensuring power on the device.
We will make a fix for this in the coming release.

For now you can fix it in a few different ways

  1. Put the included jumper on the two pins on the print board, right next to the OBD plug, as this will prevent the raspberry pi from going to sleep. But this is considered at temporary workaround, as the rpi will not go to sleep while the jumper is connected.

  2. By modifying a file
    Open this file:
    /var/cache/salt/minion/extmods/utils/spm_conn.py

    In the noop() function insert a sleep between the send and receive command (line 80):

    def noop(self):
        self._begin_message()
    
        self.send(CMD_NOOP)
    --> time.sleep(0.01)
        self.recv(ack=ACK_NOOP)
    

We will come up with a better solution and this will automatically be pushed to your device.

Let me know if it works.


#15

So, thereā€™s no way to ā€˜get startedā€™ without activating online first, ie. sending an email and waiting for a response back?


#16

Hi @Ameel_Beesony,

Unfortunately right now this is the only way. But usually support replies within a couple of hours.

But we are working on ways to make this more automated, so that you can do it on your own.

best
Peter


#17

Is there a guide that exists for the DIY assembly? I am having problems getting my autopi working, and I am unable to find an extensive guide for initial assembly. Thanks!


#18

Sorry, guys. Still looking for that jumper. Canā€™t remember where I put it! :frowning:


#19

Hi @earth,

Iā€™ve updated the guide with some images of how to connect your Zero to the AutoPi.

best
Peter


#20

Thank you!! Very helpful. A similar guide for the RPi 3 DIY edition would be great too. I finally have my RPi 3 + dongle set up with a touchscreen. Just need to install the touchscreen dashboard add-on.