Error updating dongle to 1.2.4

Subject of the issue

my dongle is presently on 1.2.2 but is trying to upgrade itself to 1.2.4. The install is failing over and once with the following error in the log:

Unable to install from VCS checkout/opt/autopi/se05x_sss. Error: Looking in indexes: Simple index, piwheels - Simple index Obtaining file:///opt/autopi/se05x_sss Requirement already satisfied: asn1 in /usr/local/lib/python2.7/dist-packages (from ssscli==4.1.1) (2.5.0) Requirement already satisfied: cffi in /usr/local/lib/python2.7/dist-packages (from ssscli==4.1.1) (1.15.1) Requirement already satisfied: click in /usr/local/lib/python2.7/dist-packages (from ssscli==4.1.1) (7.1.2) Requirement already satisfied: cryptography in /usr/lib/python2.7/dist-packages (from ssscli==4.1.1) (2.6.1) Requirement already satisfied: func_timeout in /usr/local/lib/python2.7/dist-packages (from ssscli==4.1.1) (4.3.5) Requirement already satisfied: future in /usr/local/lib/python2.7/dist-packages (from ssscli==4.1.1) (0.18.2) Requirement already satisfied: pysha3 in /usr/local/lib/python2.7/dist-packages (from ssscli==4.1.1) (1.0.2) Requirement already satisfied: enum-compat in /usr/local/lib/python2.7/dist-packages (from asn1->ssscli==4.1.1) (0.0.3) Requirement already satisfied: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi->ssscli==4.1.1) (2.21) Requirement already satisfied: enum34; python_version < “3.4” in /usr/lib/python2.7/dist-packages (from enum-compat->asn1->ssscli==4.1.1) (1.1.6) Installing collected packages: ssscli Attempting uninstall: ssscli Found existing installation: ssscli 4.1.1 DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.3.dev0 ERROR: Exception: Traceback (most recent call last): File “/usr/local/lib/python2.7/dist-packages/pip/_internal/cli/base_command.py”, line 188, in _main status = self.run(options, args) File “/usr/local/lib/python2.7/dist-packages/pip/_internal/cli/req_command.py”, line 185, in wrapper return func(self, options, args) File “/usr/local/lib/python2.7/dist-packages/pip/_internal/commands/install.py”, line 407, in run use_user_site=options.use_user_site, File “/usr/local/lib/python2.7/dist-packages/pip/_internal/req/init.py”, line 64, in install_given_reqs auto_confirm=True File “/usr/local/lib/python2.7/dist-packages/pip/_internal/req/req_install.py”, line 675, in uninstall uninstalled_pathset = UninstallPathSet.from_dist(dist) File “/usr/local/lib/python2.7/dist-packages/pip/_internal/req/req_uninstall.py”, line 545, in from_dist link_pointer, dist.project_name, dist.location) AssertionError: Egg-link does not match installed location of ssscli (at /opt/autopi/se05x_sss) WARNING: You are using pip version 20.1.1; however, version 20.3.4 is available. You should consider upgrading via the ‘/usr/bin/python -m pip install --upgrade pip’ command.

Your environment

  • What version is the dongle? (Find on software state page on my.autopi.io)
    1.2.2

Steps to reproduce

Tell us how to reproduce this issue.
Just request an update to the latest version from the UI

Expected behaviour

Tell us what you expect should happen
The 1.2.4 release should install and not fail

Actual behaviour

Tell us what happens instead
System is trying to install with failusers

Output of power.status command

If your issue is in any way related to the device shutting down or behaving in a unexpected way, please provide the output of the power.status command to help us diagnose the issue.

Run the command

power.status

in the terminal on local.autopi.io, and paste the result here.

Do’s & dont’s

  • Do not write your unit-id anywhere.