Cannot update: Error Master URI

After trying to enque the update for a week and nothing happened I tried today to use the command to force the update; but I only get error

When running the command I can hear the AutoPi talking stating that its retrying the update.

When in phoner using the Terminal via local admin website I only get error:

local user@Local device$ minionutil.update_release
error: ‘’‘master_uri’’’

I have not yet pulled out any logs since I was doing this on my phone, will try my laptop tomorrow.
Any ideas on what to try?=

1 Like

Hi, it looks like if you have change the cloud api, the upgrade will not work. Try to reset the cloud api url & token and make the update.
If i remember well, the update will be made at the start up. So you should have a trip, stop your car, and it should be good.
Hope it will help.

2 Likes

Oh?
Tried getting some logs out yesterday but no success…
I need to search on what you mean “reset” API.
Or do you mean Re-register the whole device?! (New token n everything)

1 Like

Hi.
I mean, u maybe should reset your settings if u already changed it.
About thoses settings i mean that one :


It’s maybe not your case, but in my case I put back the default values (with the reset button) and with this configuration i was able to make the upgrade.

What is currently the behavior of your dongle? Can u see the wifi, are u able to see it in the local mode?

1 Like

I didnt have time to check yesterday but before I left the car at the parkinglot I pulled the plug and am going to plug it in again once my shift ends.I noticed that It has not communicated with the server since 7 days ago. (But I have been able to use it locally as Wifi-HotSpot and connect to it with it saying that its online).

Regarding Cloud API. I dont have those reset buttons :open_mouth:

Regarding Cloud API. I dont have those reset buttons :open_mouth:
If u didnt change it, it doesnt appear. So its ok.

It has not communicated with the server since 7 days ago
Your dongle is not saying all the time some thing as “4G is disconnected”?

It didnt before, but still offline today but I could surf from the device. But I think my dongle is all bust, as in I need to reflash it.
If only the extraction of the key wasnt so hard if one like me was a Windows Person :slight_smile:

This was taken after a drive to work while on parking lot and Engine on.
It shows all OK :confused:
Anyway, pulled it out and am going to see if I can somehow re-flash it while dead time at work.

Could you try to go to the local.autopi.io with a “private” window of FF/Chrome, just to be sure.
For me, it looks really strange that your dongle says “yes i am connected” and at the same time the cloud is saying that you are not…

I KNOW RIGHT!! :open_mouth:

I tried both FF and Chrome on my phone but will try the incognito when I get back to my car after work, I forgot my screwdriver so I cannot re-flash it at work :yum:

It says the same if I login through incognito mode. All green…

Did a reflash and since it still won’t connect AND it is still showing green. Cloud.status says connection error. I verified that is has the old ID still
Screenshot_20191221-134546_ConnectBot

Will have to make a ticket… Again… Sigh

They updated the image on the Github to the latest and once again I tried that before contacting support. It didnt help to reflash it once more.

I contacted support whom after a short conversation understood my issue and told me to run these commands.

When the device is online next, can you try to run the following commands through the terminal?

saltutil.refresh_pillar
power.sleep confirm=true

This should trigger the update process, now just leave the device, some time later you should be able to see the update state of the device on my.autopi.io changed to “updated”.

By golly IT WORKED!
My device is now reporting Data to the cloud (which actually sounds way worse than it should) and I can now control it via my cloud page!

This issue will be marked as solved!
Edit: How do I mark things as Solved?

1 Like