AutoPi is not staying connected, trouble starting

Subject of the issue

AutoPi is not staying connected, trouble starting

Your environment

  • What version is the dongle? (Find on software state page on my.autopi.io)
    AutoPi Telematics Unit - 4G/LTE Edition - RPi 3
    2020.05.27

Steps to reproduce

Plug in the device. Blue light blinks. Blue light becomes solid and white light blinks. White becomes Green and solid. I am able to connect to the device hotspot and go to local settings. I sometimes see the 2 green connections on the top of local indicating everything is connected correctly. I sometimes be able to go through the hotspot and connect to the internet on my phone through a browser. I verified this by also turning off mobile data while still browsing the internet. I cannot and never have been able to connect through internet (my.autopi.io) to my device.

Expected behaviour

Device should stay online and I should be able to connect from my.autopi.io

Actual behaviour

See above

Hi Kevin.

We’re sorry to hear that you’re having issues with your AutoPi device. Just to confirm, have you registered the device on my.autopi.io? Also, is it the case that the device is connected to the internet (i.e. you can browse the internet through your phone while you’re connected to the AutoPi hotspot), but the device doesn’t show up in your account on my.autopi.io?

Best
Nikola

Nikola,

Yes. The AutoPi is registered and appears in local and global. Yes, I can browse the internet on my phone sometimes. It is rare but that to me proves the 4G is working at some point. The device is in the account but it transmits very little data. For example, I have pending configuration changes that have not synced since I changed them. I do see some events transmitted also. However, it does not hold and the red/green icon on the top next to the device name drop down, is almost always red.

Hi Kevin.

It sounds like you might be having issues with cell signal to your device. You can test out the connection signal by running the following command either in your web terminal or by SSHing into your device locally:

qmi.signal_strength

Please note that if you’re running the command through SSH you need to prepend the autopi command, like so:

autopi qmi.signal_strength

This should show you some output which will tell you what the signal strength is and might help you further debug the issue. You can view our documentation for more information on the commands you can execute on your AutoPi device here.

One last thing you can try is to try connecting to a local hotspot through the device. You can do that by connecting to the AutoPi device’s hotspot and navigating to local.autopi.io through your phone. Once logged in, you should be able to see a WiFi tab, where you’re able to create a new connection to an SSID and specify the password. If the connection problems persist, I suggest that you escalate the issue to our support system. You can do that by writing to support@autopi.io where the issue can be investigated more.

Best
Nikola

Nikola,

I honestly thing something is wrong with my device. It is still not connecting over 4G to the AutoPi cloud. Here are some screen prints from the signal strength. Seems like it should be good enough. I am now having trouble staying connected via the local device connection. In the first image, you can see it seems to be conected to the AutoPi Cloud. I have not tried on Wifi yet.

I am having exactly the same issue and it is exasperating

I’m not 100% sure if it’s the same issue, but I had where connecting from my laptop or phone to the AutoPi device was incredibly unstable. I changed the the country_code in /etc/hostapd from the default (UK or GB) to my country canada, and rebooted and it was fine.

This might also controlled by the setting is “Settings -> System -> Locale”, however I’m not sure and if the device can’t talk with the cloud it was of no help.