Autopi causing entertainment system crashes on Kona Electric?

Has anyone else experienced random crashes of the media (entertainment) system with the autopi installed in a Kona Electric recently?

I’ve had it sitting on my desk for the past 3-4 months or so. Before that, it was in the car for about a month. I haven’t experienced a single crash in that time.

I’ve recently installed it in the car again, and had 5-6 crashes in a timespan of 2 weeks. It might be a coincidence, but it’s one hell of a coincidence.

That’s not the only thing…
Sleep is completely messed up.

It keeps waking up with reason “heartbeat timeout” 4 minutes after going to sleep.
It’s set to sleep for 2 hours before waking up again.
Voltage threshold for wakeup is set well above the current aux battery voltage (13.2V, or +0.2V).

And to add to that, this is the trip recorded on the Dashboard:

… and this is the last recorded trip under Trips:

The car has been sitting on the parking lot for the past 1h45m.
I’m yanking the dongle out, it’s more trouble than it’s worth right now.

Hi Ante

Can you send us the log file from the device?
Basically the heartbeat timeout only occurs when the system does not respond, and should not happen under normal circumstances.

Regarding the entertainment system crashes you experience, then it would be interesting to see what loggers are configured on your device, as the device is very much capable of sending any and all data it’s told, even something that could interfere with something else, so maybe there is a PID that somehow interferes with other systems.

Best regards

Sent you the logs via private message.
I’ve included minion, syslog and daemon.log, since those seemed relevant.
Let me know if you need anything else.

I’m still having the same issue with trips.
This is the Dashboard:

This is Trips:

My trip start regexp is set to vehicle/obd/bus_connected, and trip end to vehicle/battery/discharging, which seems reasonable / should work.

Regarding crashes - these are my loggers:

All of these are from the library, and i had no issues with them months ago, the first time around. I don’t use CAN bus for anything, and besides both the OBD port and the entertainment system are firewalled.

I do have a splitter connected to the OBD port and am running a Navdy HUD in parallel with the autopi. It isn’t really set up to do anything with the bus apart from checking for a few non-existent PIDs, though. Also, i’ve had it in the car for about 7-8 months now without any issues whatsoever. So i doubt that’s the culprit.

Considering the crashes have been completely random, my bet would be some kind of EMI on the bus, or a voltage spike.

Any ideas on what might be causing the heartbeat timeouts?

@Malte anything? At least a “we’re looking into it”?

Can i at least get an “issue closed due to inactivity” here? :slight_smile:

Hi Ante,
Sorry about the crazy long delay :expressionless:

I have tried to sum up the issues here.

  1. Entertainment system crashes
    It’s really hard to say what could cause the issue, and as you say it seems random, so it sounds like it is either some voltage spike or maybe a race condition somehow.

    Were you using the OBD split cable when the issues occurred?
    Have you tried another cable? Maybe better quality or shorter etc?
    Have you tried disabling all the loggers, just to see if that fixes the issue?

  2. The trips looking weird.
    The dashboard will by default show all data from the last two hours, but that is a bit confusing as that means that the device has logged the whole route, but why is that not shown when selecting the trip.
    It makes me think there is an issue with trip regex, or since the trip has a ‘valid’ duration, ie. not zero or something like that, it could be an issue related to the timezone when querying the data :thinking:

    Could you try changing the user timezone to UTC in the profile settings?

  3. The heartbeat timeouts
    This happens when the raspberry pi does not send the heartbeat to the power manager chip in a period - but it’s hard to say why it fails in this case, as I don’t see anything obvious in the logfiles. I do however see some errors when it attempts to connect to the modem. Have you had any issues with the LTE connection?
    Can you send an email to with this issue, to get a ticket?

Best regards

1 Like

[quote=“Malte, post:8, topic:1595”]
Were you using the OBD split cable when the issues occurred?[/quote]

Yes, the same one i’ve been using up to that point (without any crashes). Nothing was connected to the other end of the splitter at the time, though.

I haven’t, good point, i have a short male-to-female extension somewhere i can try.

It didn’t occur to me because i haven’t changed them in any way since day 1. Will give it a try.

I’ll give it a shot.

Yeah, i haven’t noticed anything obvious in the logs either. I’ve had some spotty LTE connectivity on powerup/wake here and there, usually it’d connect after a while.