4G internet setup troubleshooting

4G internet setup troubleshooting

You are experiencing issues connecting to the internet, when connected to the WiFi hotspot on the AutoPi Dongle.

Prerequisites:

Before following this guide, you must have completed the initial setup guide found here:

Check SIM card

  1. Your SIM card must be setup for data. To check this, insert the SIM into another device, like a smartphone or similar. When inserted in the other device you must be able to browse the web.

  2. If you ordered a branded version of the AutoPi (Verizon/AT&T), please verify that the network carrier of the SIM card is the same as the brand of the AutoPi.

  3. Verify that the SIM card is not pin locked and if it is that you have entered the pin code in the settings.

Check Modem on Hardware

In the terminal on the WiFi, check that the modem has been found. This can be done by writing the following command:

cmd.run "lsusb"

The output of the command should be similar to this:

The important part to look for is the USB device named "2c7c:0121". This is the modem.

If you ordered a 4G edition and you don’t find the modem in your list, then please contact support@autopi.io

Checking qmi-manager status

The device contains a software manager, which ensure stable connection to the internet. This is called qmi-manager. To check status, please write the following command in the terminal:

cmd.run "qmi-manager status"

The output should be similar what you can see in the image below:

Further checking of network

If your device still isn’t online, you can try running the following two commands. They will tell you a bit more about why the network manager fails:

cmd.run "qmi-manager down"
cmd.run "qmi-manager up"

If the last command reports issue with detecting the SIM card, then double check the orientation of the SIM card and try again.

Tweaks

If you experience connection issues where the connection drops sometimes and/or if it is online, but not shown as online on my.autopi.io, then you can try to tweak the MTU from the default value: 1500, to a lower value, in increments (ex. 1500 -> 1450 -> etc).
This can be done on the local configuration tool, by connecting to the device hotspot and opening local.autopi.io in your browser.

If the connection is still not online, then please contact support@autopi.io for additional help.

Hi

I followed your steps.
Unfortunately the last command does not work:

grafik

As you can see on the screenshot it gives me:
“An error occurred. Received INTERNAL SERVER ERROR from server.”

Any advice would be much appreciated

kind regards
Tobias

Hi

After playing around with commands qmi.cell_info and qmi.system_info i found out that HSDPA+ is not supported. I had to activate the LTE option with a new mobile plan and voila it is working.

kind regards
Tobias

Hi Tobias,

I’m glad you got it figured out. In case you have anything else, just send a message to support and they will be able to help you also.

br
Peter

Hi Tobias,

I am getting similar problems with my SIM card. (Error while bringing up minion for multi-master. Is master at hub01.autopi.io responding?)

I am in Canada and using Bell as Cellular network. Connection to the network is working but I am getting very high latency. Would you mind sharing the output of qmi.system_info for your current setup?

It seems that my SIM card is configured for HSDPA+ (hsdpa-hsupa), but LTE is not enabled. You will find below the output of qmi.system_info command on my AutoPi.

Thanks in advance.

qmi.system_info
[/dev/cdc-wdm0] Successfully got system info:
WCDMA service:
Status: ‘available’
True Status: ‘available’
Preferred data path: ‘no’
Domain: ‘cs-ps’
Service capability: ‘cs-ps’
Roaming status: ‘off’
Forbidden: ‘no’
Location Area Code: ‘XXXXX’
Cell ID: ‘XXXXXXXX’
MCC: ‘XXX’
MNC: ‘XXX’
HS call status: ‘(null)’
HS service: ‘hsdpa-hsupa-supported
Primary scrambling code: ‘XXX’
Cell broadcast support: ‘off’
Call barring status (CS): ‘all-calls’
Call barring status (PS): ‘all-calls’
Cipher Domain: ‘ps’
LTE service:
Status: 'none’
True Status: ‘none’
Preferred data path: ‘no’
TD-SCDMA service:
Status: ‘none’
True Status: ‘none’
Preferred data path: ‘no’
SIM reject info: ‘available’"

Hi I have same problem sim not connect to autopi

Hi @Ritesh_Dilipkumar,

Have you tried the terminal commands described in troubleshooting guide above?

best
Peter

I followed your steps.
Hot-spot is working and the dongle appear sto be connected to the cloud and appears to be talking to the car (it’s a 2018 Ioniq EV so that may be adding a wrinkle):

However, my.autopi.io is not getting any data and shows it as not connected (this is connecting to my.autopi.io through the hot-spot)

Any help or hints would be appreciated.

qmi-manager status:

qmi.system_info and qmi.cell_info:

The end of minionutil.last_logs:

Hi Stuart

What provider are you using?

Best regards
/Malte

Hi Malte,

Rogers (Canada).

Thanks,
Stuart

What more can I provide you to help? I’m still not connected.

Hi Stuart

Can you send an email to support@autopi.io?

Best regards
/Malte

I’ve tried many times and different ways to working the Autopi with SIM but doesn’t work also for me.

I’m located in Italy and I’ve correctly setup the APN with mobile.vodafone.it my carrier is Vodafone. I’ve tested the SIM into mobile phone and works correctly with very high signal. I’ve also remove SIM PIN from mobile phone and put again into AutoPI but doesn’t work. The SIM is correctly inserted into the Autopi because I can hear also the standard “click” of sim plug in.

The AutoPI works correctly in Wifi but I need to use SIM card and not WiFi. I’ve also followed the instruction wrote here and the modem is correctly identified with 2c7c:0121

When I tried to run the next command cmd.run “qmi-manager status” the command is not recognized.

I’ve also tried cmd.run “qmi-manager up” and cmd.run “qmi-manager down” but unfortunately give errors.

Could you kindly help me please?

Today I’ve purchased TIM italian SIM that is supported in your list but unfortunately after paing fee of SIM also this have problem to connect to cloud.

I’ve used the standard already saved APN wap.tim.it

Please help me

This is the screenshot after the command launched locally.

Seems that the modem is installed but could not find the SIM card. The error in the first screen is NO SIM CARD PRESENT.

Support could you help me?

Hi Matteo,

I can see that you’ve already in progress with support, so lets take the discussion there.

The APN settings for TIM Italy is: ibox.tim.it

Best
Peter